Bug 1196770 - Cannot create router
Summary: Cannot create router
Keywords:
Status: CLOSED DUPLICATE of bug 1193582
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 17:12 UTC by Forrest Taylor
Modified: 2015-02-26 17:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-26 17:18:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Forrest Taylor 2015-02-26 17:12:29 UTC
Description of problem:
After deployment of RHEL-OSP Installer on a single controller and single compute node, I cannot create a router, neither as admin nor as a regular user.


Version-Release number of selected component (if applicable):
2015-02-23.2 6.0-RHEL-7
2015-02-17.1 6.0-RHEL-7-Installer

openstack-neutron-openvswitch-2014.2.2-3.el7ost.noarch
python-neutronclient-2.3.9-1.el7ost.noarch
openstack-neutron-2014.2.2-3.el7ost.noarch
openstack-neutron-ml2-2014.2.2-3.el7ost.noarch
python-neutron-2014.2.2-3.el7ost.noarch


After deployment, login to Horizon or use the command line to create a router:

[root@mac525400000000 ~(openstack_admin)]# neutron router-create test
Internal Server Error (HTTP 500) (Request-ID: req-8db4a11b-2c44-4502-9152-095f266c7da7)


Logs:
2015-02-26 12:07:07.901 19215 ERROR neutron.api.v2.resource [req-8db4a11b-2c44-4502-9152-095f266c7da7 None] create failed
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource Traceback (most recent call last):
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/resource.py", line 87, in resource
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource     result = method(request=request, **args)
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/base.py", line 448, in create
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource     obj = obj_creator(request.context, **kwargs)
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/db/l3_hamode_db.py", line 360, in create_router
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource     self.delete_router(context, router_dict['id'])
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/openstack/common/excutils.py", line 82, in __exit__
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource     six.reraise(self.type_, self.value, self.tb)
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/db/l3_hamode_db.py", line 356, in create_router
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource     self._create_ha_interfaces(context, router_db, ha_network)
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/db/l3_hamode_db.py", line 299, in _create_ha_interfaces
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource     num_agents = self.get_number_of_agents_for_scheduling(context)
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/db/l3_hamode_db.py", line 265, in get_number_of_agents_for_scheduling
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource     num_agents=num_agents)
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource HANotEnoughAvailableAgents: Not enough l3 agents available to ensure HA. Minimum required 2, available 1.
2015-02-26 12:07:07.901 19215 TRACE neutron.api.v2.resource 
2015-02-26 12:07:07.902 19215 INFO neutron.wsgi [req-8db4a11b-2c44-4502-9152-095f266c7da7 None] 172.24.0.12 - - [26/Feb/2015 12:07:07] "POST /v2.0/routers.json HTTP/1.1" 500 371 0.380284

Comment 5 Mike Burns 2015-02-26 17:18:36 UTC

*** This bug has been marked as a duplicate of bug 1193582 ***


Note You need to log in before you can comment on or make changes to this bug.