Bug 119678 - KAlarm crashes because there isn't a Sound Card to Utilize
KAlarm crashes because there isn't a Sound Card to Utilize
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: arts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-04-01 09:10 EST by Brandon Petersen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 07:30:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brandon Petersen 2004-04-01 09:10:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
The first time that I attempted to use Kalarm and create an alarm
event caused Knotify to crash and cause a signal 11.  This is most
likey due to the fact that there isn't a sound card in the computer
and the alarm event was set to use sound.

This appears to only have happened the first time I attempted to do
this.  The second time I got the message, 'During the previous
startup, KNotify crashed while instantiating Knotify.  Do you want to
try again or disable aRts sound output.



Version-Release number of selected component (if applicable):
kdeutils-3.2.1 and arts-1.2.1-1.1

How reproducible:
Sometimes

Steps to Reproduce:
1. Started kalarm from the Accessories menu
2. Went to the Actions Menu and selected 'New'
3. Typed in a short description of the alarm and checked the sound box
4. It then click the 'Try' button on the bottom of the dialog

Actual Results:  Knotify crashed and caused a signal 11.

Expected Results:  The test alarm should just appear and the app
should probably alert me to the fact that there is not a sound card
setup on the computer.

Additional info:

This backtrace appears to be useless.
This is probably because your packages are built in a way which
prevents creating of proper backtraces, or the stack frame was
seriously corrupted in the crash.

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread -150887776 (LWP 1885)]
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...0x005a77a2
in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x005a77a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x007fea93 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x002264a4 in KCrash::defaultCrashHandler () from
/usr/lib/libkdecore.so.4
#3  <signal handler called>
#4  0x05b90c8a in KAudioManagerPlay::KAudioManagerPlay ()
   from /usr/lib/libartskde.so.1
#5  0x00c68091 in KNotify::restartedArtsd () from /usr/lib/kde3/knotify.so
#6  0x00c63dcf in KNotify::KNotify () from /usr/lib/kde3/knotify.so
#7  0x00c63350 in kdemain () from /usr/lib/kde3/knotify.so
#8  0x0804cba6 in ?? ()
#9  0x00000001 in ?? ()
#10 0x09301940 in ?? ()
#11 0x00000001 in ?? ()
#12 0x09305200 in ?? ()
#13 0x00000000 in ?? ()
Comment 1 Ngo Than 2004-04-15 07:30:55 EDT
it should be fixed in KDE 3.2.2 which will be available in rawhide 
soon 

Note You need to log in before you can comment on or make changes to this bug.