Bug 1196795 - Fuse RPM creates "fuse" group with random GID < 500
Summary: Fuse RPM creates "fuse" group with random GID < 500
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fuse
Version: 6.5
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Carlos Maiolino
QA Contact: Zorro Lang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 18:50 UTC by Eric
Modified: 2016-01-07 20:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-07 20:08:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eric 2015-02-26 18:50:47 UTC
Description of problem:
The fuse and fuse-libs RPMs were installed as a dependency of Gluster.  Fuse created a group (fuse) for its-self with GID 107.  Trying to install libvirt later errored because 107 is a reserved GID for libvirt.  

The gid selected seems to be random and below 500.  Another install used gid 313.  A third install selected gid 106. 


Version-Release number of selected component (if applicable):
fuse-libs-2.8.3-4.el6.x86_64
fuse-2.8.3-4.el6.x86_64


How reproducible:
Three out of three attempts.


Steps to Reproduce:
1.  yum install -y fuse



Actual results:


Expected results:


Additional info:

Comment 5 Carlos Maiolino 2016-01-07 20:08:35 UTC
Eric,

users/applications are allowed to dynamically create system groups between the range specific for that.

Fuse dynamically create fuse group inside the range allowed by the system, where, in Red Hat Enterprise Linux 6, the default range for dynamically allocated GIDs starts at GID 201, reserving the first 200 GIDs for statically allocated groups (like qemu group at gid 107).

There is no bug here since fuse group is being dynamically allocate based on system's configuration.

Please check your /etc/login.defs and check if the variable SYS_GID_MIN is set for anything below 201.

Feel free to re-open the bug in case you find something misbehaving according to the expected behavior above.

-Carlos


Note You need to log in before you can comment on or make changes to this bug.