Bug 1196816 - Updating to Rawhide from F21 using yum stalls at installing cockpit-ws
Summary: Updating to Rawhide from F21 using yum stalls at installing cockpit-ws
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: cockpit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik Perpeet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 19:46 UTC by Gerard Ryan
Modified: 2015-03-24 09:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-24 09:21:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Gerard Ryan 2015-02-26 19:46:05 UTC
Description of problem:
I've been trying to update an F21-server VM to Rawhide, but it kept stalling at the installation of cockpit-ws (not an 'upgrade', since that subpackage doesn't exist for f21...I guess it gets pulled in by something else). I had a VM snapshot, so I was able to prove it reproducible. I was also able to do a complete successful upgrade to Rawhide by first removing cockpit altogether from F21, then doing the "yum distro-sync".

How reproducible:
Seems to be 100% of the time currently.

Steps to Reproduce:
1. From a cleanly installed, then updated F21 server, attempt to jump to Rawhide, following the steps on the wiki: https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#To_rawhide

Actual results:
Rawhide packages get downloaded, and start to update. When the cockpit-ws package is being applied, it appears to hang.

Expected results:
It doesn't hang.

Comment 1 Gerard Ryan 2015-02-26 19:59:17 UTC
I've just successfully run "yum install cockpit" on the newly updated Rawhide, so the problem seems to be limited to upgrade from "latest F21" -> "latest Rawhide" (or maybe broader, I haven't tried F22 -> Rawhide).

Comment 2 Fedora Admin XMLRPC Client 2015-03-03 15:11:34 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Dominik Perpeet 2015-03-18 17:48:14 UTC
tracked here https://github.com/cockpit-project/cockpit/issues/1943

Comment 4 Dominik Perpeet 2015-03-20 08:40:19 UTC
This works for me, detailed output in https://github.com/cockpit-project/cockpit/issues/1943.

This may have been a temporary Rawhide issue. Is it still broken for you?

Comment 5 Gerard Ryan 2015-03-22 01:25:12 UTC
Hi Dominik,

I don't currently have time to test this. I just saw it once when I was upgrading a VM and figured I'd report it. To work around it, I just removed cockpit before upgrade, then installed again after. If you've proven it to work now, that's plenty good enough for me! :)


Note You need to log in before you can comment on or make changes to this bug.