This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 119682 - Rebuilding without SELinux support dies
Rebuilding without SELinux support dies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 09:20 EST by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-01 11:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-04-01 09:20:38 EST
Description of problem:
Rebuilding without SELinux dies, because there is a file 
(%{_sbindir}/sesh) added with the SELinux patch and that file isn't 
conditional in the files section.

Version-Release number of selected component (if applicable):
sudo-1.6.7p5-24

How reproducible:
Rebuild sudo without SELinux support
  
Actual results:
--- sudo.spec      2004-04-01 16:14:31.000000000 +0200
+++ sudo.spec.rsc  2004-04-01 16:18:15.000000000 +0200
@@ -78,7 +78,9 @@
 %dir /var/run/sudo
 %attr(4111,root,root) %{_bindir}/sudo
 %attr(0755,root,root) %{_sbindir}/visudo
+%if %{WITH_SELINUX}
 %attr(0755,root,root) %{_sbindir}/sesh
+%endif
 %{_mandir}/man5/sudoers.5*
 %{_mandir}/man8/sudo.8*
 %{_mandir}/man8/visudo.8*

Expected results:
Please add this or a better fix, because if the SELinux support is
conditional, it should be working both ways... - thank you :)
Comment 1 Thomas Woerner 2004-04-01 11:18:39 EST
Fixed in rawhide in rpm sudo-1.6.7p5-25 or newer.

Note You need to log in before you can comment on or make changes to this bug.