Bug 119689 - Profiling launch configuration can proceed without specifying C/C++ launch configuration
Profiling launch configuration can proceed without specifying C/C++ launch co...
Status: CLOSED NOTABUG
Product: Red Hat Developer Suite
Classification: Retired
Component: Profiling Plug-in (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Keith Seitz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 10:15 EST by Jeremy Handcock
Modified: 2007-04-18 13:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-01 12:02:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Handcock 2004-04-01 10:15:53 EST
Description of problem: When defining a new Oprofile launch
configuration, you can proceed without specifying a corresponding
C/C++ launch configuration.


Version-Release number of selected component (if applicable):
snapshot-20040331


How reproducible: Always


Steps to Reproduce:
1. Define a new Profiling launch configuration
2. Don't specify a corresponding C/C++ launch configuration
  
Actual results: You are allowed to continue (and even run oprofile)
without specifying a C/C++ launch configuration.


Expected results: The user shouldn't be allowed to continue without
specifying a C/C++ launch configuration.  The dialog should probably
do setFinish(false) or whatever it is if the C/C++ launch config entry
box is empty or invalid (invalid == the C/C++ launch config entered
doesn't actually exist).
Comment 1 Keith Seitz 2004-04-01 12:02:02 EST
Actually this is the intended behavior. A system-wide profiler does
not necessarily need anything special to run it. What if I want some
sort of system performance baseline to compare what my application
does to the system?

Note You need to log in before you can comment on or make changes to this bug.