Bug 1196952 - dnf repoquery does not provide -f like yum-utils
dnf repoquery does not provide -f like yum-utils
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
: Reopened
: 1190991 1197054 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-27 01:22 EST by Jens Petersen
Modified: 2015-04-21 15:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.6-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-21 15:26:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2015-02-27 01:22:20 EST
Description of problem:
yum-utils repoquery can search for files with -f

eg $ repoquery -f /usr/lib64/libsyck.so

but it seems dnf repoquery does not support this yet?

Version-Release number of selected component (if applicable):
dnf-0.6.4-1.fc21

How reproducible:
100%

Steps to Reproduce:
1. dnf repoquery -f /usr/lib64/libsyck.so

Actual results:
Using metadata from Fri Feb 27 14:41:00 2015
usage: dnf repoquery [--help-cmd] [--repoid REPO] [--arch ARCH]
                     [--whatprovides REQ] [--whatrequires REQ] [--querytags]
                     [-i | -l | --qf QUERYFORMAT | --conflicts | --enhances | --obsoletes | --provides | --recommends | --requires | --suggests | --supplements]
                     [key]

Expected results:
syck-devel

Additional info:
I find "repoquery -f" extremely useful for linking files to packages,
I do hope it could be implemented soon in dnf-plugins-core.
Comment 1 Jens Petersen 2015-03-01 04:17:24 EST
Okay "dnf provides" seems to do what I want (if slightly verbosely).
Comment 2 Jens Petersen 2015-03-01 04:40:11 EST
(In reply to Jens Petersen from comment #1)
> Okay "dnf provides" seems to do what I want (if slightly verbosely).

Well more precisely:

  dnf provides /usr/lib64/libsyck.so

tell me which package NVR has the file but of course dnf provides does not
support --qf.
Comment 3 Jan Zeleny 2015-03-02 03:17:50 EST

*** This bug has been marked as a duplicate of bug 1190991 ***
Comment 4 Honza Silhan 2015-03-02 08:15:00 EST
*** Bug 1197054 has been marked as a duplicate of this bug. ***
Comment 5 Honza Silhan 2015-03-02 08:16:11 EST
*** Bug 1190991 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2015-04-09 10:41:07 EDT
dnf-plugins-core-0.1.6-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.6-3.fc22
Comment 7 lnie 2015-04-10 04:56:12 EDT
dnf-plugins-core-0.1.6-3.fc22 works
Comment 8 Fedora Update System 2015-04-10 14:21:36 EDT
Package dnf-plugins-core-0.1.6-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.6-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5951/dnf-plugins-core-0.1.6-3.fc22
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2015-04-21 15:26:12 EDT
dnf-plugins-core-0.1.6-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.