Bug 1196975 - wacom bamboo ctl-460 kill X
Summary: wacom bamboo ctl-460 kill X
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Tissoires
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-27 08:54 UTC by bionan_2000
Modified: 2015-04-18 09:56 UTC (History)
10 users (show)

Fixed In Version: xorg-x11-drv-synaptics-1.8.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-30 07:05:43 UTC
Type: Bug


Attachments (Terms of Use)
xorg.log (7.50 KB, text/plain)
2015-02-27 08:54 UTC, bionan_2000
no flags Details
Information asked in comment 1 (6.23 KB, application/zip)
2015-03-15 17:25 UTC, bionan_2000
no flags Details
evemu-describe wacom bamboo (1.87 KB, text/plain)
2015-03-17 22:14 UTC, bionan_2000
no flags Details
evemu-describe bamboo pen finger (2.24 KB, text/plain)
2015-03-17 22:15 UTC, bionan_2000
no flags Details
evemu-describe bamboo pen pen (2.29 KB, text/plain)
2015-03-17 22:16 UTC, bionan_2000
no flags Details
hid-recorder (341.18 KB, text/plain)
2015-03-24 21:32 UTC, bionan_2000
no flags Details

Description bionan_2000 2015-02-27 08:54:56 UTC
Created attachment 995930 [details]
xorg.log

Description of problem:

Excuse me my poor english.
When i connect the wacom bamboo ctl-460 the X system
is imediatly kill with a segment fault.

Version-Release number of selected component (if applicable):


How reproducible:
Just connect the bamboo tablet and the X is killed with a segment fault

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
In attachment the Xorg.log

Comment 1 Peter Hutterer 2015-03-11 05:10:57 UTC
looks like it's the synaptics driver crashing here. what's the version of xorg-x11-drv-synaptics? and can you install xorg-x11-drv-synaptics-debuginfo and attach a new stacktrace, that may give us more info.

Also, pls attach the output of evemu-describe so we can try to reproduce this here.

Comment 2 bionan_2000 2015-03-12 14:09:28 UTC
Sorry my english... and i'm a newbie too...

1 - version synaptics: 

xorg-x11-drv-synaptics-1.8.1-4.fc21.x86_64

2 - xorg-x11-drv-synaptics-debuginfo

In what repository is xorg-x11-drv-synaptics-debuginfo?

3 - attach the output of evemu-describe

How i do that?

Comment 3 Peter Hutterer 2015-03-12 22:17:27 UTC
2) debuginfo packages are usually in the fedora-debuginfo repo which is disabled by default (check your /etc/yum.repos.d/), the easiest way is to run debuginfo-install <package-name>.
3) see http://www.freedesktop.org/wiki/Evemu for instructions

Comment 4 bionan_2000 2015-03-15 17:25:08 UTC
Created attachment 1002012 [details]
Information asked in comment 1

Information, i hope..., asked in comment 1

Comment 5 bionan_2000 2015-03-15 17:29:15 UTC
I install de debuginfo package of synaptics, run evemu-describe and evemu-record of computer touchpad (/dev/input/event6 in my case) redirecting the output to a file.

Then a attached the wacom bamboo in my computer and, as espected, the X crashed.

Comment 6 Peter Hutterer 2015-03-17 05:52:33 UTC
oh, this is the touchpad recording. what causes the crash is the wacom bamboo, please attach a evemu describe of that device. Given that your X server crashes do the following:
hit ctrl+alt+f2 to get to a VT, log in there. plug the device in, run the evemu command, then unplug the device. ctrl+alt+f1 gets you back to the X server.

if the server keeps crashing despite being on the VT (shouldn't happen) you can run: sudo systemctl stop gdm.service
and then do all the above, followed by a systemctl start gdm.service


(also, for the future: pls don't attach zip files, just attach the files as-is)

Comment 7 bionan_2000 2015-03-17 22:14:07 UTC
Created attachment 1002963 [details]
evemu-describe wacom bamboo

Comment 8 bionan_2000 2015-03-17 22:15:45 UTC
Created attachment 1002964 [details]
evemu-describe bamboo pen finger

Comment 9 bionan_2000 2015-03-17 22:16:53 UTC
Created attachment 1002965 [details]
evemu-describe bamboo pen pen

Comment 10 bionan_2000 2015-03-17 22:18:10 UTC
(In reply to Peter Hutterer from comment #6)
> oh, this is the touchpad recording. what causes the crash is the wacom
> bamboo, please attach a evemu describe of that device. Given that your X
> server crashes do the following:
> hit ctrl+alt+f2 to get to a VT, log in there. plug the device in, run the
> evemu command, then unplug the device. ctrl+alt+f1 gets you back to the X
> server.
> 
> if the server keeps crashing despite being on the VT (shouldn't happen) you
> can run: sudo systemctl stop gdm.service
> and then do all the above, followed by a systemctl start gdm.service
> 
> 
> (also, for the future: pls don't attach zip files, just attach the files
> as-is)

As always forgive me my poor english.

Following your instructions, hit ctrl+alt+f2 to get a VT and pluging the device in, crashed the X server. Then i try the systemctl command and pluging the device and again the X server crashed.

Then i started my system with init 3 then i run the evemu-describe command. I attached the files: bamboopenpen, bamboopenpad and bamboopenfinger.

I don't know with a did the right thing... it's all rocket science for me :)

Comment 11 Peter Hutterer 2015-03-19 10:20:53 UTC
(In reply to bionan_2000 from comment #10)
> As always forgive me my poor english.

no need to apologise, neither of us is a native english speaker and it really doesn't matter as long as we understand each other :)


Benjamin - have a look at this please. the Finger device has ABS_MT_SLOT and ABS_MT_TRACKING_ID but is missing ABS_MT_POSITION_X/Y. That's what's segfaulting the synaptics driver.

Comment 12 Fedora Update System 2015-03-24 06:25:28 UTC
xorg-x11-drv-synaptics-1.8.1-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.8.1-6.fc22

Comment 13 Fedora Update System 2015-03-24 06:41:16 UTC
xorg-x11-drv-synaptics-1.8.1-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.8.1-6.fc21

Comment 14 Peter Hutterer 2015-03-24 06:42:14 UTC
Note that the synaptics packages merely avoid the crash in the synaptics driver, they don't fix the root cause of the bug which is still a kernel issue.

Comment 15 Benjamin Tissoires 2015-03-24 13:14:29 UTC
Sorry, I meant to respond to that yesterday (for the kernel part) but I got lost trace of it.

I was sure that we fixed the pen only bamboos in the late kernel, so this surprise me a little.

Can you install hid-replay[1], and record some traces of your bamboo by executing:
$> sudo hid-recorder /dev/hidraw*

Use the pen, eraser and buttons so I can have a complete overview of the device.

[1] http://bentiss.github.io/hid-replay-docs/Fedora.html

Comment 16 bionan_2000 2015-03-24 21:31:19 UTC
ok, I installed the hid-recorder and used the bamboo with inkscape where I draw some lines and another operacions.
I attached the results of hid-recorder.
I hope this is what you wanted.
Thanks for all  efforts from you and Mr. Peter.

Comment 17 bionan_2000 2015-03-24 21:32:08 UTC
Created attachment 1005999 [details]
hid-recorder

Comment 18 Benjamin Tissoires 2015-03-25 18:37:18 UTC
(In reply to bionan_2000 from comment #16)
> I attached the results of hid-recorder.
> I hope this is what you wanted.

Yep, this is what I wanted. I am able to reproduce the problem now and should come up with a kernel fix soon or later.

Comment 19 Fedora Update System 2015-03-27 01:50:05 UTC
xorg-x11-drv-synaptics-1.8.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.8.2-1.fc22

Comment 20 Fedora Update System 2015-03-29 04:39:05 UTC
Package xorg-x11-drv-synaptics-1.8.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.8.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4865/xorg-x11-drv-synaptics-1.8.2-1.fc22
then log in and leave karma (feedback).

Comment 21 Fedora Update System 2015-03-30 07:05:43 UTC
xorg-x11-drv-synaptics-1.8.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Benjamin Tissoires 2015-04-06 16:22:04 UTC
Just a FYI, I am not sure what I was able to reproduce the other day (I might have run it under a 3.18 too).

Anyway, this was already fixed upstream by this commit https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=30ebc1aea8ce02da5b3789eba775dd2d79837813 , included in v3.19.

Comment 23 Fedora Update System 2015-04-18 09:56:11 UTC
xorg-x11-drv-synaptics-1.8.1-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.