Bug 11970 - /etc/rc.d/init.d/xfs makes font.dir when it shouldn't
/etc/rc.d/init.d/xfs makes font.dir when it shouldn't
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-08 00:27 EDT by Joe Acosta
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-15 14:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2000-06-08 00:27:57 EDT
It seems that xfs makes the font.dir files on every boot or every time that
the xfs start script is run.  I installed sharefont and freefont for the
gimp as it uses them in some of its scripts as defaults. I then used xset
+fp to add them in my current session and added them in to the
/etc/X11/fs/config filesystem. The fonts were installed in
/usr/X11R6/lib/X11/fonts. They worked that night. When I restarted the
system and tried to access the fonts the gimp scripts failed. *gimp scripts
= xtns->script fu->logos (pick one) they all filed if I used the default
font. I did an rgrep and found that mkfontdir is run on boot in the xfs
script.
My current workaround is by installing them in /public/fonts and then
running xset +fp when I start gnome (part of gnome startup).

I looked at the xfs script and it looks like it is supposed to check if the
fonts.dir exists and it still overwrites the fonts.dir for the freefont and
sharefont.  The mere fact that it overwrites the file is not the big
issue.  The big issue is that when it does overwrite these files it creates
a zero byte size file for the freefont and sharefont directories.
Comment 1 Bill Nottingham 2000-07-15 14:26:15 EDT
Reassigning to XFree86, that's where the xfs init script lives.
Comment 2 Preston Brown 2000-08-30 15:59:30 EDT
font handling for Type1 fonts has been fixed for 7.0, so that fonts.dir is not
overwritten with a 0-byte file.

Note You need to log in before you can comment on or make changes to this bug.