Bug 119715 - Upgrade to FC2t2 did not see existing swap parttiion
Upgrade to FC2t2 did not see existing swap parttiion
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 14:09 EST by Xavier Bachelot
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 18:12:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Bachelot 2004-04-01 14:09:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When upgrading from FC1 to FC2 test2, Anaconda did not see the
existing swap partition, which is located on an LVM partition, and
proposed to create a swap file instead.

I don't know if the swap partition being on an LVM partition is
significant here.

Also the comment was talking about kernel 2.4 needing a lot of swap,
this is obviously to be changed to kernel 2.6 (which does not need as
much swap as 2.4, if I recall correctly ?)

Version-Release number of selected component (if applicable):
anaconda-9.91-7

How reproducible:
Didn't try

Steps to Reproduce:
1. Upgrade to FC2 test2
2.
3.
    

Actual Results:  Anaconda did not detect the existing swap partition

Expected Results:  Anaconda uses the existing swap partition and goes
on quietly

Additional info:
Swap partition is on LVM
Comment 1 Jeremy Katz 2004-04-05 18:01:25 EDT
Hmmm, possible.  Is the swap listed in /etc/fstab?
Comment 2 Xavier Bachelot 2004-04-05 19:04:52 EDT
Yes it is

However I tried on another machine with the same configuration (swap
part on LVM fs) and it didn't show up again.
Comment 3 Jeremy Katz 2004-09-22 15:14:00 EDT
Does this work with FC3 test releases?
Comment 4 Xavier Bachelot 2004-10-15 08:38:52 EDT
I've tried again (this time upgrading from FC2 to FC3 test 3) and it
worked as expected but as I've already stated in comment #2, it does
not happen everytime. 

Note You need to log in before you can comment on or make changes to this bug.