Bug 1197181 - something happened to system's vimrc - colors got fluorescent, unreadable
Summary: something happened to system's vimrc - colors got fluorescent, unreadable
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-27 17:05 UTC by lejeczek
Modified: 2015-09-23 00:22 UTC (History)
11 users (show)

Fixed In Version: 7.4.827-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-22 08:29:43 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot demonstrating the change (209.55 KB, image/png)
2015-03-11 14:52 UTC, Cole Robinson
no flags Details
former vimrc (1.99 KB, text/plain)
2015-03-11 15:27 UTC, lejeczek
no flags Details
unreadable syntax highlighting in vim (111.41 KB, image/png)
2015-04-22 12:05 UTC, Martin Kolman
no flags Details

Description lejeczek 2015-02-27 17:05:34 UTC
Description of problem:


Version-Release number of selected component (if applicable):

vim-common-7.4.640-3.fc22.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Cole Robinson 2015-03-11 14:52:37 UTC
Created attachment 1000530 [details]
Screenshot demonstrating the change

The file on the left is opened with vim-7.4.629-2.fc22.x86_64
The file on the right is opened with vim-7.4.640-4.fc22.x86_64

The left is the expected colors, right side is all bold and wonky.

If this is intentional, can someone provide steps on how to revert to the old behavior?

Comment 2 lejeczek 2015-03-11 15:27:55 UTC
Created attachment 1000542 [details]
former vimrc

bottom 5 lines are custom

Comment 3 Cole Robinson 2015-03-21 15:24:41 UTC
Karsten, do you know if these color changes are expected?

Comment 4 Cole Robinson 2015-03-30 19:17:15 UTC
FWIW I tried the new vim build in koji, vim-7.4.663-2.fc23. Still broken

Comment 5 Martin Kolman 2015-04-22 12:05:42 UTC
Created attachment 1017383 [details]
unreadable syntax highlighting in vim

I have updated to F22 Beta with Fedup yesterday and I have similar issues with vim, but made worse in my case as I'm using white background in the terminal.

vim version:
vim-7.4.640-4.fc22

Comment 6 Martin Kolman 2015-04-22 12:21:53 UTC
I found a possible workaround - using :set background=light makes the vim colors much more readable. But O think it still does not look like the "old" colors on the screenshot in comment 1.

Comment 7 lejeczek 2015-04-22 16:56:46 UTC
also as a workaround, at least for me it worked, is to use vimrc I attached earlier.

Comment 8 Cole Robinson 2015-04-22 17:12:21 UTC
Hmm I wrote a comment but apparently didn't submit it...

The suggestion of using 'set background=light' does fix things for me, thanks Martin!

The change is due to bug 1159920 which added this to /etc/vimrc:

" rhbz 1159920
if $COLORTERM=="gnome-terminal"
     set background=light
else
     set background=dark
endif

Which even though I'm using gnome-terminal (but not the default color scheme) that ends up setting background=dark, which is what causes the color changes.

Comment 9 Salvador Ortiz 2015-05-30 02:14:03 UTC
And the change due to bug 1159920 conflicts with bug 1166428, F22 uses a new vte that don't set COLORTERM anymore.

Anyway, because COLORTERM is common, now I add the following to .bashrc:

if [ -n "$VTE_VERSION" ]
    export COLORTERM=gnome-terminal
fi

Regards.

Comment 10 Illtud Daniel 2015-06-20 00:04:52 UTC
Me too. Thanks for workaround in Comment 9, but please fix! Terrible!

Comment 11 lejeczek 2015-06-27 18:17:50 UTC
none of these last fixes helps me when I use custom terminal profiles, and customization only for colors and fonts

Comment 12 Karsten Hopp 2015-09-22 08:29:43 UTC
This is supposed to be fixed in vim-7.4.827-1.fc22, please update your vim packages and reopen this bugzilla if the colors are still wrong with your terminal.

Comment 13 Fedora Update System 2015-09-23 00:21:35 UTC
vim-7.4.827-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.