Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1197283 - Anaconda master kn.po content is broken
Summary: Anaconda master kn.po content is broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Zanata
Classification: Retired
Component: Component-zanata-client
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Ding-Yi Chen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-28 01:17 UTC by Brian Lane
Modified: 2015-03-03 07:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-02 01:44:34 UTC


Attachments (Terms of Use)

Description Brian Lane 2015-02-28 01:17:08 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build Identifier: 

I'm not sure which component to file this against. The kn.po file that was pulled is returning errors when processed with /usr/bin/msgfmt -c --statistics --verbose -o kn.gmo kn.po it reports errors on lines 22, 1310, 2398 and 2625 because it has multiple plural entries when it is only supposed to have one.

I edited it to remove the extra msgstr[1] entries and pushed the changes back up (using zanata-python-client). On the next pull the file was still broken.


Reproducible: Always

Comment 1 Ding-Yi Chen 2015-03-02 01:44:34 UTC
This is because the plural format specified in kn.po is wrong.
The correct plural forms should be 
"Plural-Forms: nplurals=2; plural=(n != 1);"

I have fixed the plural-forms for kn so you can pull the kn.po with 

zanata-cli -B pull --locales kn

This should solve the "too many plural forms" error.

Comment 2 Brian Lane 2015-03-02 17:50:40 UTC
It would be helpful if things like this could be caught on the server side so that pulling doesn't result in broken files.

Comment 3 Carlos Munoz 2015-03-02 23:29:43 UTC
Ding, could you work with Brian to file an RFE if this is a necessary feature.

Comment 4 Ding-Yi Chen 2015-03-03 01:05:34 UTC
Two RFE bugs have been filed:

1. Checking when po is uploading via web UI: Bug 1197925
2. Checking when po is pushing via zanata-client: 1197927
3. Checking when po is pushing via zanata-python-client: 1197928

Comment 5 Ding-Yi Chen 2015-03-03 07:03:16 UTC
Correction:

Following RFE bugs have been filed:

1. Checking when po is uploading via web UI: Bug 1197925
2. Checking when po is pushing via zanata-client: Bug 1197927
3. Checking when po is pushing via zanata-python-client: Bug 1197928


Note You need to log in before you can comment on or make changes to this bug.