Bug 1197302 - [3.5-7.1] Sosreport doesn't work
Summary: [3.5-7.1] Sosreport doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks: 1197441 1198482
TreeView+ depends on / blocked
 
Reported: 2015-02-28 06:58 UTC by cshao
Modified: 2016-03-09 14:26 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1198482 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:26:31 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 38272 master MERGED recipe: Add patch for sos-3.2 2020-05-13 10:10:49 UTC
oVirt gerrit 38327 ovirt-3.5 ABANDONED recipe: Add patch for sos-3.2 2020-05-13 10:10:49 UTC

Description cshao 2015-02-28 06:58:59 UTC
Description of problem:
[3.5-7.1] Sosreport doesn't work.

# sosreport
sosreport (version 3.2)
no valid plugins were enabled

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150226.0.el7ev
ovirt-node-3.2.1-7.el7.noarch
sos-3.2-15.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H 7.1 via pxe.
2. Run command "sosreport" in shell.
3.

Actual results:
sosreport doesn't work

Expected results:
sosreport can work fine.


Additional info:
No such issue with 7.0 build.
# cat /etc/issue
Red Hat Enterprise Virtualization Hypervisor 7.0 (20150127.0.el7ev)
# rpm -qa | grep sos
sos-3.0-23.el7_0.4.noarch

So consider this is a regression bug from 7.0 to 7.1.

Comment 2 Yaning Wang 2015-03-02 09:49:48 UTC
according to sos-3.0-23.el7_0.4.noarch

in file 

sos/utilities.py

line 212, 218

    if "__init__" not in plugin and plugin.endswith(".py")]

    py_files = list(find("*.py", path))


But in RHEVH image, only *.pyc left in sos/plugins directory

Comment 4 cshao 2015-03-04 05:50:34 UTC
Test version:
rhev-hypervisor7-7.1-20150226.0.iso 
(# md5sum rhev-hypervisor7-7.1-20150226.0.iso
499af21f477de875c77c66f3af0dd9df  rhev-hypervisor7-7.1-20150226.0.iso)
ovirt-node-3.2.1-9.el7.noarch
sos-3.2-15.el7.noarch

Test steps:
1. Install RHEV-H 7.1 via pxe.
2. Run command "sosreport" in shell.

Test result:
sosreport can work fine.

So I will verify this bug after status change to ON_QA.
Thanks!

Comment 8 cshao 2015-10-28 07:17:24 UTC
Test version:
rhev-hypervisor7-7.2-20151025.0.el7ev
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch
sos-3.2-35.el7.noarch

Test steps:
1. Install RHEV-H 7.2 via pxe.
2. Run command "sosreport" in shell.

Test result:
sosreport can work fine.

So the bug is fixed, change bug status to VERIFIED.

Comment 10 errata-xmlrpc 2016-03-09 14:26:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.