Bug 1197377 - Multiple usability issues during installation
Summary: Multiple usability issues during installation
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-28 22:03 UTC by Roland Illig
Modified: 2015-03-02 14:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-02 14:18:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CentOS 8249 0 None None None Never

Description Roland Illig 2015-02-28 22:03:50 UTC
Note: This is a long story revealing many things that can be improved in the installer. It’s probably best to create some sub-issues from it.

I downloaded the CentOS netinst image and started a VMware installation with it.

On the first try, I selected the standard German keyboard layout (de-nodead) and wanted to try the Sun accented keyboard. When I clicked on the keyboard test field and pressed some keys (trying to get accented characters), I pressed the menu key, then the Windows key and then Windows+H. Something moved on the screen, which looked funny. So I pressed the key again. Now the screen was completely black, and I could press any key I wanted, nothing helped. So I restarted the VM.

=> major: screen should not turn black when testing the keyboard

On the second try, I skipped the keyboard experiments and just sticked with the default settings. This led me to the “Installation Summary” screen. The first three icons looked finished, and the remaining four had an exclamation mark.

So I clicked on the first one (“Installationsquellen” in German) in order to fix it. I was faced with an empty text field where I had to enter a URL. But what kind of URL? No hints, no suggestions, nothing.

=> minor: the installer should suggest a default URL

So I had to google “centos installationsquellen”. I found some URLs that looked promising, so I copied the URL to the clipboard and then tried to paste it into the VM. That didn’t work. I had to copy-type the URL. (That’s ok, since the VMware tools haven’t been installed at this point.)

I looked for the Finish or Return button, in the lower right corner where it should be. Finally I found it in the title bar of the dialog, which is a really unusual position for such a button.

=> minor: the button should be in the lower right corner

I clicked it and returned to the Summary screen. There I saw an overly generic error message (“Fehler beim Einrichten der Basis-Datenquelle”). No hint where to look, no help, nothing. I wanted to know at least: 1. is the network connected at all? 2. is the DNS server reachable? 3. is the host reachable? 4. does the download URL return a HTTP 200? 5. does the download URL point to a valid repository? This distinction really helps in diagnosing network problems.

=> major: the status message should be more specific

Some time later, I got the idea of looking at the other items that had an exclamation mark. One of them is “Netzwerk & Hostname”. Now it was obvious that I first had to connect to a network before trying to download something via http. This dependency of actions is totally misrepresented in the installer UI. It must be communicated more clearly that a network connection is required to download something from the network. Following the reading order (top to bottom, left to right, at least for English), the Network & Hostname item should be above the Installation Source item.

=> major: the order of the icons on the screen should represent the order in which the items have to be configured. 

Since VMware starts the VM in 640x480 mode, I’m cancelling the UI installation at this point, since the screen layout for partitioning the disk is completely messed up.

=> blocker: the screen for partitioning the disk must be completely visible even in 640x480 mode

My first impression of the “base graphics” mode (which should have honestly been called “text mode”) is that it is awful.

=> minor: the text mode should be called text mode

To navigate between the different screens I cannot use Enter or Escape, but have to press C before.

=> major: having to confirm every navigation action by pressing Enter is cumbersome

The main menu suggests me to press B to begin the installation although I haven’t finished all tasks yet.

=> major: the UI should only offer choices that do something useful

Every terminal supports a ClrScr escape sequence. After finishing a screen, that screen should be hidden completely, making room for the next screen. Currently up to 3 screens are displayed at the same time, which constantly forces me to look where the separator lines are.

=> minor: before displaying a screen, the screen should be cleared

In the Create User area, menu items 4 and 5 can be combined into one. When I choose to give the user a password, the installation program should ask for the password directly. Letting the user type 4, Enter, 5, Enter, password, Enter is more complicated than necessary.

=> minor: menu items 4 and 5 should be combined into one

After half an hour of navigating through the various menus, I have finally managed to press B to begin the installation. The installation program is now “Starting package intallation process”. This already takes about 5 minutes without any feedback. This is too long.

=> major: there should be some indicator that something is happening

Now the packages are being installed. This will take a while, so I have time to look around on the screen. I notice the green bar at the bottom of the screen. First: what is the word “anaconda” supposed to mean? It doesn’t provide any useful information to me as a casual user.

=> minor: the [anaconda] text should not be shown

Second: the numbers suggest that I can press the corresponding key, that is 5 to see the program log. But the 5 is just displayed in the main screen. Without historical knowledge, it’s impossible to know that this 5 is really an abbreviation for Alt+F5.

=> major: the key labels in the lower green bar should represent the actual keys

Now the “installation is complete. Press return to quit” — Why should I quit now? I want to continue and finish the installation.

=> minor: “quit” should be replaced with a more appropriate verb, e.g. “Press return to restart the computer and boot the freshly installed system”

Comment 2 David Cantrell 2015-03-02 14:18:44 UTC
Hi Roland,

Thanks for the feedback here.  There is a lot of information here, but I'd like you to take it to another venue for discussion rather than Bugzilla.  Here's why:

1) We use Bugzilla for tracking defects from discovery to resolution.  Open-ended discussions are not really good in Bugzilla, or things that are subjective in nature (which tend to include interface design).  A defect needs a reproducer, an expected behavior, and a path to resolution.  This discussion does not really fit that criteria.

2) Bugzilla entries need to cover ONE thing.  Multiple issues per Bugzilla entry are extremely difficult for us to track and we have a policy of closing those bugs -or- requesting the reporter to reduce the scope to a single issue (opening remaining issues as other bugs).

I am going to close this bug, but I would like you to take this discussion elsewhere.  The Fedora and CentOS user discussion lists are likely able to answer a lot of your questions.  For items you want triaged as bugs, please file each one individually.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.