Bug 1197432 - macefi, cannot reuse existing Linux HFS+ ESP, requires reformatting
Summary: macefi, cannot reuse existing Linux HFS+ ESP, requires reformatting
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-01 06:29 UTC by Chris Murphy
Modified: 2015-03-03 19:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-03 19:58:11 UTC
Type: Bug


Attachments (Terms of Use)
anaconda.log (71.57 KB, text/plain)
2015-03-01 06:29 UTC, Chris Murphy
no flags Details
storage.log (362.53 KB, text/plain)
2015-03-01 06:29 UTC, Chris Murphy
no flags Details
program.log (60.43 KB, text/plain)
2015-03-01 06:29 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2015-03-01 06:29:10 UTC
Created attachment 996708 [details]
anaconda.log

Description of problem:
Existing partition /dev/sda4 from Fedora 21 installation; Manual Partitioning lets me think I can reuse it by assigning it to /boot/efi without reformatting, but back at the main menu I can't begin the installation due to a storage configuration error.
No valid boot loader target device found. See below for details.
For a UEFI installation, you must include an EFI System Partition on a GPT-formatted disk, mounted at /boot/efi.

Back in Manual Partitioning, clicking on /boot/efi and checking reformat as Linux HFS+ ESP fixes the problem.


Version-Release number of selected component (if applicable):
anaconda 22.20.1-1
python-blivet-1.0-1.fc22

How reproducible:
Always


Steps to Reproduce:
1. Install Fedora to a Mac.
2. Try to reinstall Fedora to a Mac reusing existing HFS+ EFI System partition without reformatting it (which isn't required for FAT32 ESPs).

Actual results:

Can't be done.
No valid boot loader target device found. See below for details.
For a UEFI installation, you must include an EFI System Partition on a GPT-formatted disk, mounted at /boot/efi.


Expected results:

Should be possible to reuse it.


Additional info:

Comment 1 Chris Murphy 2015-03-01 06:29:33 UTC
Created attachment 996709 [details]
storage.log

Comment 2 Chris Murphy 2015-03-01 06:29:54 UTC
Created attachment 996710 [details]
program.log

Comment 3 Brian Lane 2015-03-03 19:58:11 UTC
The problem is that the /boot/efi/ mountpoint didn't have the 'Linux HFS+ ESP' label on it, so it was rejected. In order to make sure reuse works correctly it needs to be created with that label.


Note You need to log in before you can comment on or make changes to this bug.