Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1197433 - Geo-rep: Duplicate public keys in authorized_keys on each run of create command
Summary: Geo-rep: Duplicate public keys in authorized_keys on each run of create command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-01 07:18 UTC by Aravinda VK
Modified: 2015-05-14 17:35 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-03-01 07:18:15 UTC
Description of problem:
When a node is added in Master/Slave, we have to run Geo-rep create push-pem force and Start force to distribute Master public keys to Slave nodes.

This commands adds duplicate entries in authorized_keys file of existing slave nodes.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Create push-pem geo-rep session, check the authorized_keys file in slave nodes.
2. Run Geo-rep create again with force and check the authorized_keys file in slave nodes.


Actual results:
Duplicate entries in authorized_keys file.

Expected results:
Should not be duplicate entries in authorized_keys file in slave nodes.

Additional info:

Comment 1 Anand Avati 2015-03-01 08:29:36 UTC
REVIEW: http://review.gluster.org/9776 (geo-rep: Avoid duplicate entries in authorized_keys file) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Anand Avati 2015-03-06 02:27:44 UTC
COMMIT: http://review.gluster.org/9776 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 1a2c1e9bf8d711d821fbd166ed6d7f7d9bcce69d
Author: Aravinda VK <avishwan@redhat.com>
Date:   Sun Mar 1 11:48:12 2015 +0530

    geo-rep: Avoid duplicate entries in authorized_keys file
    
    When Georep create(force) command is run multiple times
    it appends master nodes public keys to Slave nodes without
    checking the existence of the key.
    
    With this patch, create push-pem force adds pub key only if
    not available in authorized_keys.
    
    BUG: 1197433
    Change-Id: Iad57f6c45698e258ad1a547fa7a2e376a315f0cd
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/9776
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:26:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:28:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.