Bug 1197440 - Uninstallable due to missing mysql-server dependency
Summary: Uninstallable due to missing mysql-server dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: RackTables
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Coe
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-01 08:59 UTC by Anssi Johansson
Modified: 2015-03-25 20:02 UTC (History)
2 users (show)

Fixed In Version: RackTables-0.20.10-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-25 20:02:05 UTC


Attachments (Terms of Use)

Description Anssi Johansson 2015-03-01 08:59:10 UTC
Description of problem:
RackTables requires mysql-server, which is not available in EL7 or EPEL7.

Version-Release number of selected component (if applicable):
RackTables-0.20.10-1.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. yum install RackTables

Actual results:
# yum install RackTables
...
Resolving Dependencies
--> Running transaction check
---> Package RackTables.noarch 0:0.20.10-1.el7 will be installed
--> Processing Dependency: php-snmp for package: RackTables-0.20.10-1.el7.noarch
--> Processing Dependency: php for package: RackTables-0.20.10-1.el7.noarch
--> Processing Dependency: perl(Net::Telnet) for package: RackTables-0.20.10-1.el7.noarch
--> Processing Dependency: perl(Net::OpenSSH) for package: RackTables-0.20.10-1.el7.noarch
--> Processing Dependency: mysql-server for package: RackTables-0.20.10-1.el7.noarch
--> Running transaction check
---> Package RackTables.noarch 0:0.20.10-1.el7 will be installed
--> Processing Dependency: mysql-server for package: RackTables-0.20.10-1.el7.noarch
---> Package perl-Net-OpenSSH.noarch 0:0.62-1.el7 will be installed
---> Package perl-Net-Telnet.noarch 0:3.03-19.el7 will be installed
---> Package php.x86_64 0:5.4.16-23.el7_0.3 will be installed
---> Package php-snmp.x86_64 0:5.4.16-23.el7_0.3 will be installed
--> Processing Dependency: net-snmp for package: php-snmp-5.4.16-23.el7_0.3.x86_64
--> Processing Dependency: libnetsnmp.so.31()(64bit) for package: php-snmp-5.4.16-23.el7_0.3.x86_64
--> Running transaction check
---> Package RackTables.noarch 0:0.20.10-1.el7 will be installed
--> Processing Dependency: mysql-server for package: RackTables-0.20.10-1.el7.noarch
---> Package net-snmp.x86_64 1:5.7.2-18.el7 will be installed
--> Processing Dependency: net-snmp-agent-libs = 1:5.7.2-18.el7 for package: 1:net-snmp-5.7.2-18.el7.x86_64
--> Processing Dependency: libnetsnmptrapd.so.31()(64bit) for package: 1:net-snmp-5.7.2-18.el7.x86_64
--> Processing Dependency: libnetsnmpmibs.so.31()(64bit) for package: 1:net-snmp-5.7.2-18.el7.x86_64
--> Processing Dependency: libnetsnmpagent.so.31()(64bit) for package: 1:net-snmp-5.7.2-18.el7.x86_64
---> Package net-snmp-libs.x86_64 1:5.7.2-18.el7 will be installed
--> Running transaction check
---> Package RackTables.noarch 0:0.20.10-1.el7 will be installed
--> Processing Dependency: mysql-server for package: RackTables-0.20.10-1.el7.noarch
---> Package net-snmp-agent-libs.x86_64 1:5.7.2-18.el7 will be installed
--> Finished Dependency Resolution
Error: Package: RackTables-0.20.10-1.el7.noarch (epel)
           Requires: mysql-server
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
RackTables and its dependencies get installed.

Additional info:
I pointed out the missing dependency in https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0688/RackTables-0.20.10-1.el7 during testing, but my recommendation to not push this update to stable before this issue is resolved was apparently ignored.

Comment 1 Fedora Update System 2015-03-02 01:12:30 UTC
RackTables-0.20.10-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/RackTables-0.20.10-2.el7

Comment 2 Colin Coe 2015-03-02 01:15:14 UTC
RackTables-0.20.10-2.el7 should be in the EPEL testing soon.

Please let me know how this goes.

Comment 3 Fedora Update System 2015-03-04 13:27:15 UTC
RackTables-0.20.10-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/RackTables-0.20.10-5.el7

Comment 4 Fedora Update System 2015-03-08 22:39:33 UTC
Package RackTables-0.20.10-5.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing RackTables-0.20.10-5.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1043/RackTables-0.20.10-5.el7
then log in and leave karma (feedback).

Comment 5 Anssi Johansson 2015-03-11 15:47:35 UTC
I run automatic nightly repoclosure tests on EPEL testing packages, and the previous RackTables update was one of the problematic packages. Looks like repoclosure no longer complains about missing dependencies any more with the new package, thanks.

Comment 6 Fedora Update System 2015-03-25 20:02:05 UTC
RackTables-0.20.10-5.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.