Bug 119748 - (440GX) interrupt routing is broken. ACPI ??
Summary: (440GX) interrupt routing is broken. ACPI ??
Status: CLOSED DUPLICATE of bug 107880
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-01 22:57 UTC by Florin Andrei
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florin Andrei 2004-04-01 22:57:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
Well, the L440GX+ bug is still not fixed. Booting up the test2 install
CD on a L440GX+ dual-Xeon system (fortunately not hit by the test2
installer CD boot bug ;-)) and it hangs at "Loading SCSI driver" with
message "Loading aic7xxx driver..."
Some stuff i see in the virt consoles:
The Alt-F3 console: i see "loaded mii", "loaded e100", "loaded
aic7xxx" but then only "inserted mii" and "inserted e100" but no
"inserted aic7xxx" (i'm not quoting exactly).
The Alt-F4 console: i see the beginning of the SCSI driver messages,
like the first 3 or 4 lines or so, but that's where it hangs, it
doesn't detect any devices, or anything.
It just hangs, and that's pretty much it.

Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.253.2.1

How reproducible:
Always

Steps to Reproduce:
1.Boot up test2 on a L440GX+ system
2.
3.
    

Actual Results:  The installer hangs when loading up the SCSI driver.

Expected Results:  The installer should not hang.

Additional info:

Comment 1 Alan Cox 2004-05-03 14:30:42 UTC
Does acpi=force fix this ? - or test3. The Intel guys were submitting
a fix upstream for the pirq routing bug.


Comment 2 Florin Andrei 2004-05-03 16:00:22 UTC
With acpi=force, i can boot up FC2test3 just fine.
It's just the installer that needs the parameter. Once installed, it
makes no difference whether i use the parameter or not, it works anyway.
It's a dual-CPU PIII, if that has any importance.

Comment 3 Alan Cox 2004-05-03 19:22:54 UTC
Thanks.. should get fixed entirely with the upstream intel change then.

The bit that matters is the chipset. We had a bug in dealing with it
in non ACPI mode due to a little difference of design opinion between
it and the kernel. 2.4 got a fix, 2.6 slipped it.


Comment 4 Len Brown 2004-05-19 22:37:31 UTC

*** This bug has been marked as a duplicate of 107880 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:02:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.