This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 119753 - 32-bit GDB missing
32-bit GDB missing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gdb (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 18:21 EST by Sreevatsa Nagarajarao
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 08:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sreevatsa Nagarajarao 2004-04-01 18:21:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
To debug 32-bit programs running under ia32el (ia32el-1.0-2) requires
a copy of 32-bit gdb (gdb-6.0post-0.20040223.6.i386.rpm) also running
under ia32el. In addition, it requires the following rpms,

  bash-2.05b-29.i386.rpm
  libtermcap-2.0.8-35.i386.rpm

Also, strace support for 32-bit programs requires
strace-4.5.1-1.EL.1.i386.rpm.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Run a 32-bit program using gdb or strace. 

    

Actual Results:  64-bit gdb and 64-bit strace cannot be effectively
used on 32-bit programs because they show the internal workings of the
execution layer.

Additional info:
Comment 1 Sreevatsa Nagarajarao 2004-04-01 18:24:46 EST
The bug was filed against gdb because there was no ia32el component.
Comment 4 Elena Zannoni 2004-08-27 08:51:09 EDT
This is now fixed, as those packages are available.
Comment 5 John Flanagan 2004-12-21 14:37:05 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-561.html

Note You need to log in before you can comment on or make changes to this bug.