Bug 1197546 - Rescue boot fails since dm-thinpool.ko is not included in initrd.img of RHS iso
Summary: Rescue boot fails since dm-thinpool.ko is not included in initrd.img of RHS iso
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-storage-server
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Sreenath G
QA Contact: Sachidananda Urs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-02 01:35 UTC by Takahiro HASHIMOTO
Modified: 2019-06-13 08:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-08 05:46:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
anaconda error when rescue booting with RHS 3.0.3 iso (3.23 KB, text/plain)
2015-03-02 01:35 UTC, Takahiro HASHIMOTO
no flags Details

Description Takahiro HASHIMOTO 2015-03-02 01:35:55 UTC
Created attachment 996925 [details]
anaconda error when rescue booting with RHS 3.0.3 iso

Description of problem:

Rescue boot fails since dm-thinpool.ko is not included in initrd.img of RHS iso

Version-Release number of selected component (if applicable):

RHS 3.0.3 (latest iso)

How reproducible:

After install RHS and configure gluster volumes with dm-thinpool, boot rescue mode with RHS 3.0.3 iso media.

Steps to Reproduce:
1. Install RHS and configure gluster volume with dm thinpool.
2. Shut down
3. Boot rescue mode from RHS 3.0.3 cdrom

Actual results:

rescue boot fails due to error of "/usr/lib/anaconda/storage/devicelibs/lvm.py"(see attached error)

Expected results:

rescue boot successfully.

Additional info:

RHS3 uses dm-thinpool based LVs for handle snapshots. I think the initrd.img in iso should contain dm-thinpool.ko.

I confirmed that dm-thinpool.ko isn't included in following isos.

RHEL6.x dvd iso
RHS3.0.3 iso

And it's included in iso of RHEL7.

Could you consider update iso of RHS?


Note You need to log in before you can comment on or make changes to this bug.