Bug 1197598 - NFS logs are filled with system.posix_acl_access messages
Summary: NFS logs are filled with system.posix_acl_access messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: 3.6.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1197253
Blocks: glusterfs-3.6.3
TreeView+ depends on / blocked
 
Reported: 2015-03-02 07:52 UTC by Niels de Vos
Modified: 2016-02-04 15:20 UTC (History)
3 users (show)

Fixed In Version: glusterfs-v3.6.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1197253
Environment:
Last Closed: 2016-02-04 15:20:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-03-02 07:52:58 UTC
+++ This bug was initially created as a clone of Bug #1197253 +++

+++ This bug was initially created as a clone of Bug #1196057 +++

Description of problem:
======================

NFS logs are getting filled with below messages :

[2015-02-25 06:21:12.993029] I [dict.c:371:dict_get] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/debug/io-stats.so(io_stats_getxattr_cbk+0xf6) [0x7ff08c07ea86] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(nfs_fop_getxattr_cbk+0x2f) [0x7ff087dba91f] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(acl3_getacl_cbk+0x8d) [0x7ff087de4e5d]))) 0-dict: !this || key=system.posix_acl_access
[2015-02-25 06:21:12.995279] I [dict.c:371:dict_get] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/debug/io-stats.so(io_stats_getxattr_cbk+0xf6) [0x7ff08c07ea86] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(nfs_fop_getxattr_cbk+0x2f) [0x7ff087dba91f] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(acl3_getacl_cbk+0x8d) [0x7ff087de4e5d]))) 0-dict: !this || key=system.posix_acl_access
[2015-02-25 06:21:12.997439] I [dict.c:371:dict_get] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/debug/io-stats.so(io_stats_getxattr_cbk+0xf6) [0x7ff08c07ea86] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(nfs_fop_getxattr_cbk+0x2f) [0x7ff087dba91f] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(acl3_getacl_cbk+0x8d) [0x7ff087de4e5d]))) 0-dict: !this || key=system.posix_acl_access
[2015-02-25 06:22:30.395445] I [dict.c:371:dict_get] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/debug/io-stats.so(io_stats_getxattr_cbk+0xf6) [0x7ff08c07ea86] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(nfs_fop_getxattr_cbk+0x2f) [0x7ff087dba91f] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(acl3_getacl_cbk+0x8d) [0x7ff087de4e5d]))) 0-dict: !this || key=system.posix_acl_access
[2015-02-25 06:22:30.405158] I [dict.c:371:dict_get] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/debug/io-stats.so(io_stats_getxattr_cbk+0xf6) [0x7ff08c07ea86] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(nfs_fop_getxattr_cbk+0x2f) [0x7ff087dba91f] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/nfs/server.so(acl3_getacl_cbk+0x8d) [0x7ff087de4e5d]))) 0-dict: !this || key=system.posix_acl_access


Version-Release number of selected component (if applicable):
=============================================================

current mainline

How reproducible:
=================
100%


Steps to Reproduce:
1. Mount NFS volume and run IO.

--- Additional comment from Anand Avati on 2015-02-28 00:01:17 CET ---

REVIEW: http://review.gluster.org/9773 (nfs: prevent logging missing 'system.posix_acl_*' xattrs) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-03-02 08:49:49 CET ---

COMMIT: http://review.gluster.org/9773 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 4f143bfe4eabc34c5682a3b0421092e5e22ee507
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Feb 27 23:47:26 2015 +0100

    nfs: prevent logging missing 'system.posix_acl_*' xattrs
    
    The nfs.log gets spammed with messages that the system.posix_acl_access
    and system.posix_acl_default xattrs are not set. The logging happens
    because the dictionary that contains the xattrs is empty/NULL in case
    the getxattr() did not return any contents for the ACLs.
    
    Change-Id: Id31e30635146599915c6d8674a2dde065f348adc
    BUG: 1197253
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9773
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Meghana M <mmadhusu@redhat.com>

Comment 1 Anand Avati 2015-03-02 07:55:44 UTC
REVIEW: http://review.gluster.org/9780 (nfs: prevent logging missing 'system.posix_acl_*' xattrs) posted (#1) for review on release-3.6 by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2015-03-07 14:23:32 UTC
COMMIT: http://review.gluster.org/9780 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 4a49d0bf260d000aeae185f9f21f589a6ee01618
Author: Niels de Vos <ndevos@redhat.com>
Date:   Mon Mar 2 08:54:15 2015 +0100

    nfs: prevent logging missing 'system.posix_acl_*' xattrs
    
    The nfs.log gets spammed with messages that the system.posix_acl_access
    and system.posix_acl_default xattrs are not set. The logging happens
    because the dictionary that contains the xattrs is empty/NULL in case
    the getxattr() did not return any contents for the ACLs.
    
    Cherry picked from commit 4f143bfe4eabc34c5682a3b0421092e5e22ee507:
    > Change-Id: Id31e30635146599915c6d8674a2dde065f348adc
    > BUG: 1197253
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/9773
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Meghana M <mmadhusu@redhat.com>
    
    BUG: 1197598
    Change-Id: I100a05706038753f2036968870d86911b830ca14
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9780
    Reviewed-by: Meghana M <mmadhusu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 3 Anand Avati 2015-03-09 05:07:39 UTC
REVIEW: http://review.gluster.org/9829 (nfs: prevent logging missing 'system.posix_acl_access' xattrs) posted (#1) for review on release-3.6 by Meghana M (mmadhusu@redhat.com)

Comment 4 Anand Avati 2015-03-09 20:52:18 UTC
COMMIT: http://review.gluster.org/9829 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 57d2ba0582010a45fa286e22ad4b9e2a6e3d3bae
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Feb 27 23:47:26 2015 +0100

    nfs: prevent logging missing 'system.posix_acl_access' xattrs
    
    Change http://review.gluster.org/9773 addresses the majority of the
    logging, but it seems it is still possible to trigger the excessive
    logging by requesting the ACL on files directly. Lets squash those too.
    
    Change-Id: Iced2b90997a6172655797c9bb7bf2a682814371d
    BUG: 1197598
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9829
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 5 Kaushal 2016-02-04 15:20:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.3, please open a new bug report.

glusterfs-v3.6.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2015-April/021669.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.