Bug 1197600 - libvirt should remove the pid file of vm after vm offline if we restart libvirtd after start the vm
Summary: libvirt should remove the pid file of vm after vm offline if we restart libvi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Michal Privoznik
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-02 07:56 UTC by Luyao Huang
Modified: 2015-11-19 06:18 UTC (History)
5 users (show)

Fixed In Version: libvirt-1.2.14-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:18:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2015-03-02 07:56:19 UTC
description of problem:
libvirt should remove the pid file of vm after vm offline if we restart libvirtd after start the vm

Version-Release number of selected component (if applicable):
libvirt-1.2.8-16.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
 
1.prepare a happy vm:

# virsh list
 Id    Name                           State
----------------------------------------------------
 7     test4                          running

2.# cat /var/run/libvirt/qemu/test4.pid
3476

3.restart libvirtd

# service libvirtd restart
Redirecting to /bin/systemctl restart  libvirtd.service

4.
# cat /var/run/libvirt/qemu/test4.pid
3476

5.destroy this vm
# virsh destroy test4
Domain test4 destroyed

6.pid file still exist
# cat /var/run/libvirt/qemu/test4.pid
3476

Actual results:
libvirt should remove the pid file of vm after vm offline if we restart libvirtd after start the vm

Expected results:
always remove the pid file when we destroy the vm

infomation:

Comment 1 Michal Privoznik 2015-03-03 10:57:06 UTC
Patch proposed upstream:

https://www.redhat.com/archives/libvir-list/2015-March/msg00047.html

Comment 2 Michal Privoznik 2015-03-03 11:11:19 UTC
And moving to POST:

commit 63889e0c775010d8d70b71d25340bab995aa83ce
Author:     Michal Privoznik <mprivozn@redhat.com>
AuthorDate: Tue Mar 3 11:51:19 2015 +0100
Commit:     Michal Privoznik <mprivozn@redhat.com>
CommitDate: Tue Mar 3 12:10:15 2015 +0100

    qemuProcessReconnect: Fill in pid file path
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1197600
    
    So, libvirt uses pid file to track pid of started qemus. Whenever
    a domain is started, its pid is put into corresponding pid file.
    The pid file path is generated based on domain name and stored
    into domain object internals. However, it's not stored in the
    status XML and therefore lost on daemon restarts. Hence, later,
    when domain is being shut down, the daemon does not know which
    pid file to unlink, and the correct pid file is left behind. To
    avoid this, lets generate the pid file path again in
    qemuProcessReconnect().
    
    Reported-by: Luyao Huang <lhuang@redhat.com>
    Signed-off-by: Michal Privoznik <mprivozn@redhat.com>

v1.2.13-39-g63889e0

Comment 4 vivian zhang 2015-06-23 08:55:56 UTC
I can produce this bug with build libvirt-1.2.8-16.el7.x86_64

Verify this with build libvirt-1.2.16-1.el7.x86_64

1. prepare a healthy guest, start it
# virsh list
 Id    Name                           State
----------------------------------------------------
 10    vm1                            running

# cat /var/run/libvirt/qemu/vm1.pid 
26848

2. restart libvirtd, and check guest pid exist
# service libvirtd restart
Redirecting to /bin/systemctl restart  libvirtd.service

# cat /var/run/libvirt/qemu/vm1.pid 
26848

3. destroy guest, check pid disappeared

# virsh destroy vm1
Domain vm1 destroyed

# cat /var/run/libvirt/qemu/vm1.pid 
cat: /var/run/libvirt/qemu/vm1.pid: No such file or directory

4. shutdown and managedsave guest to shutoff status, pid all removed automatically


move to verified

Comment 6 errata-xmlrpc 2015-11-19 06:18:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.