Bug 1197613 - mac address reported as already used when editing host
Summary: mac address reported as already used when editing host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.0.7
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-02 08:31 UTC by Fred van Zwieten
Modified: 2019-10-10 09:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:48:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2024673 None None None Never
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Fred van Zwieten 2015-03-02 08:31:57 UTC
Description of problem:
When editing an existing (bare metal) Host with an already filled in mac address, it is not possible to save the changes because the mac address is already in use. This is with DHCP integration on the capsule 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create/Deploy bare metal host using capsule with DHCP integration. Specify the correct mac address.
2. After deployment, edit the Host and change some filed (however, not the mac address) field
3.

Actual results:
Cannot save because mac address is already in use

Expected results:
Saved

Additional info:

Comment 1 RHEL Program Management 2015-03-02 14:24:42 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tom Caspy 2015-03-04 16:11:48 UTC
I just tested it with latest develop, and it seems like this may have been fixed in the networking feature.
Can you retest this with latest Sat build, to see if it works as expected?

Comment 7 Bryan Kearney 2016-04-07 13:25:33 UTC
I am clearing the needing. TOm was acking to have this re-tested and it is indeed ON_QA.

Comment 8 Sachin Ghai 2016-04-11 11:32:45 UTC
Verified with sat6.2 beta snap6.2.

I provisioned a host (discovered host to mimic bare-metal provisioning) and edited the same host and defined virtual interfaces. Interfaces were created successfully and didn't see the "mac address is already in use" error.

Later, I rebuild the host to see configured interfaces on host

Comment 11 errata-xmlrpc 2016-07-27 08:48:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.