Bug 1197717 - Compile milter-regex 2.0 for EPEL 6
Summary: Compile milter-regex 2.0 for EPEL 6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: milter-regex
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-02 13:27 UTC by Randy Holmes
Modified: 2015-03-25 20:00 UTC (History)
2 users (show)

Fixed In Version: milter-regex-2.0-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-25 20:00:45 UTC


Attachments (Terms of Use)

Description Randy Holmes 2015-03-02 13:27:50 UTC
Description of problem:Any chance of getting milter-regex 2.0 complied for EPEL 6?

The existing 1.8 is a pain with excess logging.

Thanks.

Comment 1 Paul Howarth 2015-03-02 15:38:33 UTC
Can you give this scratch build a try?

http://koji.fedoraproject.org/koji/taskinfo?taskID=9119931

I don't have an EL-6 box handling mail that I can try it on.

Comment 2 Randy Holmes 2015-03-02 17:00:11 UTC
Working well, but I had to edit /etc/rc.d/init.d/milter-regex and add OPTION="-l 4" in order to change the log level.

I tried everything I could think of to use /etc/sysconfig/milter-regex to no avail.

Reducing the log level stops it flooding /var/log/messages, but also means losing useful entries eg. when it starts or stops or reads the changed config file.

I am more than happy to give that up to stop the log flooding though.

Many thanks.

Comment 3 Paul Howarth 2015-03-02 17:38:30 UTC
Does:

OPTIONS="-l 4"

not work in /etc/sysconfig/milter-regex ?

If it doesn't, that's a bug.

Comment 4 Randy Holmes 2015-03-02 18:28:43 UTC
Yes, it is working.  I thought I tried every possible combination.

Comment 5 Fedora Update System 2015-03-02 20:48:32 UTC
milter-regex-2.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/milter-regex-2.0-1.el6

Comment 6 Randy Holmes 2015-03-03 07:37:27 UTC
Any idea how long until it is part of the EPEL downloads?

I really appreciate your quick work on this.

Comment 7 Paul Howarth 2015-03-03 08:30:12 UTC
It should be available in the epel-testing repository later today, and will take a couple of weeks before it gets pushed to epel proper, unless at least a couple of people test it and give positive feedback using the update link above.

Comment 8 Fedora Update System 2015-03-08 22:48:07 UTC
Package milter-regex-2.0-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing milter-regex-2.0-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1159/milter-regex-2.0-1.el6
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-03-25 20:00:45 UTC
milter-regex-2.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.