Bug 1197721 - FTBFS: test-utf8 fails on big-endian machines
Summary: FTBFS: test-utf8 fails on big-endian machines
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 22
Hardware: ppc64
OS: Linux
high
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2015-03-02 13:34 UTC by Karsten Hopp
Modified: 2015-03-09 08:27 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-03-09 08:27:51 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2015-03-02 13:34:34 UTC
Description of problem:
The test-utf8 self check aborts on ppc64le:
../build-aux/test-driver: line 107: 14044 Aborted                 "$@" > $log_file 2>&1
FAIL: test-utf8

Version-Release number of selected component (if applicable):
systemd-219-4.fc22

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f22 systemd-219-4.fc22.src.rpm
2.
3.

Actual results:

Additional info:

http://cgit.freedesktop.org/systemd/systemd/commit/src/test/test-utf8.c?id=502184de0f95d3a124d4d4c77ae7a88747a0fac2   fixes this.

Comment 1 Zbigniew Jędrzejewski-Szmek 2015-03-02 13:35:53 UTC
Yeah, we'll make an update today.

Comment 2 Ngo Than 2015-03-02 16:37:15 UTC
i have tested systemd with binutils-2.25-5.fc22.s390x and cannot reproduce the issue in #868839, #872148 with new binutils anymore.

Could you please remove the workaround?

# PIE is broken on s390 (#868839, #872148)
%ifnarch s390 s390x
%global _hardened_build 1
%endif


Thanks

Comment 3 Fedora Update System 2015-03-04 01:55:40 UTC
systemd-219-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/systemd-219-6.fc22

Comment 4 Fedora Update System 2015-03-04 21:09:19 UTC
Package systemd-219-6.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-219-6.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3138/systemd-219-6.fc22
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-03-09 08:27:51 UTC
systemd-219-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.