Bug 119776 - Text mode resets upon CD change on old machine
Summary: Text mode resets upon CD change on old machine
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-02 03:00 UTC by Nathan B
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 20:46:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan B 2004-04-02 03:00:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
I have an old Pentium 1 machine which "free" reports as to having 
61688K memory. No mouse is attached and text-mode install is 
selected. 
Upon install, the machine asks to turn on swap memory immediately.

If I select no packages along with the basic install, only CD1 is 
used for the install, and this kind fo install works. Should I choose 
extra packages for the install, install proceeds but the machine 
resets all by itself when it comes time to insert the next CD.... and 
this is not good.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install in text mode
2.Turn on swap memory
3.Install multiple packages which are not on the first CD

    

Actual Results:  When it gets time to change CDs, the machine 
resets.... making a mess of the screen as anaconda reset messages go 
AWOL. Surprisingly the machine resets cleanly.

Expected Results:  It's supposed to ask me for the second CD when it 
needs it.

Additional info:

Comment 1 Jeremy Katz 2004-04-05 22:04:52 UTC
It just reboots completely?  No error messages, no flashing keyboard leds?

Comment 2 Nathan B 2004-04-06 00:40:09 UTC
Yes. It just reboots. I set the machine to install and then left it, 
hoping for it to prompt me for the next CD. I come back to find that 
the machine rebooted.

Tried again, and the machine rebooted, but I noticed that there were 
a bunch of reboot messages staggering accross the screen and making a 
mess of the install display - over where there was supposed to be a 
CD change prompt. The messages appeared to be typical shutdown ones, 
as if install had finished, but it all happened so fast that I didn't 
notice any error mesages or flashing lights on the keyboard.

It's really slow to install and I could try to watch for errors again 
(and specifically what package was the last one to be installed) but 
I need to find time for that.

Comment 3 Nathan B 2004-04-07 01:06:09 UTC
I noticed that this CD drive could be a SCSI CD drive. I booted it up 
in Knoppix, and it labelled it as /dev/scd0
Whatever the Red Hat 9 text installer does, it doesn't give this 
machine any problems.

Comment 4 Nathan B 2004-04-08 00:40:09 UTC
Tried another install. Here's where things get interesting. 

This PC I'm using has a 1.2GB HD. I tried an install which used both 
CD1 & 3, and the packages totalled about 750MB. Install nearly 
completed, and the CD change went flawlessly. Near the end of that 
install.... reboot city.

So I tried again. I limited the install to CDs 1&3 and this time 
packages totalled 655MB. Install completed without any problems.

A third time, I tried installing all the packages even though they 
had no chance of fitting on the HD. I get an error message before 
install.

So the issue isn't CD changing. It's got something to do with making 
an install of size greater than 700MB on this hardware.

Comment 5 Alan Cox 2004-05-03 14:29:21 UTC
Out of memory perhaps - its a big tight in 64Mb for an install.


Comment 6 Jeremy Katz 2005-09-21 20:46:43 UTC
This shouldn't be a problem with current releases and currently supported hardware

Comment 7 Nathan B 2005-09-22 03:07:30 UTC
Probably shouldn't be a problem anymore. Unfortuantely I got rid of the old 
machine, so I can't check it out with Fedora Core 4 anymore. I wouldn't worry 
about this issue any more.


Note You need to log in before you can comment on or make changes to this bug.