Bug 1197849 - [abrt] cockpit-bridge: relay_length(): cockpit-bridge killed by SIGABRT
Summary: [abrt] cockpit-bridge: relay_length(): cockpit-bridge killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cockpit
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Patrick Uiterwijk
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3d5804878217d9e66a75519a7cf...
: 1191206 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-02 18:33 UTC by Tim Waugh
Modified: 2015-03-09 08:30 UTC (History)
3 users (show)

Fixed In Version: cockpit-0.41-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-03 10:38:28 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (26.84 KB, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: cgroup (190 bytes, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: core_backtrace (8.96 KB, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: dso_list (3.85 KB, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: environ (128 bytes, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: limits (1.29 KB, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: maps (19.71 KB, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: open_fds (727 bytes, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: proc_pid_status (932 bytes, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details
File: var_log_messages (3.07 KB, text/plain)
2015-03-02 18:33 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2015-03-02 18:33:14 UTC
Description of problem:
Clicked on 'Containers'.

Version-Release number of selected component:
cockpit-bridge-0.39-1.fc22

Additional info:
reporter:       libreport-2.4.0
backtrace_rating: 4
cmdline:        /usr/bin/cockpit-bridge
crash_function: relay_length
executable:     /usr/bin/cockpit-bridge
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (9 frames)
 #4 relay_length at src/bridge/cockpithttpstream.c:457
 #5 on_pipe_read at src/bridge/cockpithttpstream.c:533
 #6 ffi_call_unix64 at ../src/x86/unix64.S:76
 #7 ffi_call at ../src/x86/ffi64.c:525
 #8 g_cclosure_marshal_generic_va at gclosure.c:1561
 #9 _g_closure_invoke_va at gclosure.c:831
 #12 dispatch_input at src/common/cockpitpipe.c:269
 #16 g_main_context_iteration at gmain.c:3869
 #17 run_bridge at src/bridge/bridge.c:420

Potential duplicate: bug 1191206

Comment 1 Tim Waugh 2015-03-02 18:33:18 UTC
Created attachment 997183 [details]
File: backtrace

Comment 2 Tim Waugh 2015-03-02 18:33:19 UTC
Created attachment 997184 [details]
File: cgroup

Comment 3 Tim Waugh 2015-03-02 18:33:21 UTC
Created attachment 997185 [details]
File: core_backtrace

Comment 4 Tim Waugh 2015-03-02 18:33:22 UTC
Created attachment 997186 [details]
File: dso_list

Comment 5 Tim Waugh 2015-03-02 18:33:23 UTC
Created attachment 997187 [details]
File: environ

Comment 6 Tim Waugh 2015-03-02 18:33:25 UTC
Created attachment 997188 [details]
File: limits

Comment 7 Tim Waugh 2015-03-02 18:33:26 UTC
Created attachment 997189 [details]
File: maps

Comment 8 Tim Waugh 2015-03-02 18:33:28 UTC
Created attachment 997190 [details]
File: open_fds

Comment 9 Tim Waugh 2015-03-02 18:33:29 UTC
Created attachment 997191 [details]
File: proc_pid_status

Comment 10 Tim Waugh 2015-03-02 18:33:30 UTC
Created attachment 997192 [details]
File: var_log_messages

Comment 11 Stef Walter 2015-03-03 10:38:28 UTC
This should be fixed by this commit:

commit 9d7b8b1bfbae0af79688062ab88783f89318b83b
Author: Stef Walter <stefw@redhat.com>
Date:   Tue Feb 24 12:21:06 2015 +0100

    bridge: Keep a reference on a possibly closing HTTP channel
    
    Because the CockpitChannel may close during this function call
    hold a reference to the object.
    
    Reviewed-by: Marius Vollmer <marius.vollmer@redhat.com>


In release cockpit-0.40

Comment 12 Stef Walter 2015-03-03 10:39:04 UTC
Please reopen if 0.40 doesn't fix the issue for you.

Comment 13 Tim Waugh 2015-03-03 11:28:51 UTC
Works fine here. Thanks.

Don't forget that F22 needs bodhi updates now...

Comment 14 Fedora Update System 2015-03-03 12:37:00 UTC
cockpit-0.40-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/cockpit-0.40-1.fc22

Comment 15 Stef Walter 2015-03-03 12:38:15 UTC
Thanks Tim.

Comment 16 Stef Walter 2015-03-03 20:12:14 UTC
*** Bug 1191206 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2015-03-04 16:15:15 UTC
cockpit-0.41-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/cockpit-0.41-1.fc22

Comment 18 Fedora Update System 2015-03-09 08:30:24 UTC
cockpit-0.41-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.