Bug 1197902 - [Fedora] Large translated document push times are inconsistent
Summary: [Fedora] Large translated document push times are inconsistent
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Maven, Performance, Component-zanata-client, Component-zanata-client-ivy (Show other bugs)
(Show other bugs)
Version: 3.5
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
: 3.6
Assignee: Patrick Huang
QA Contact: Damian Jansen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Zanata-3.6.1
TreeView+ depends on / blocked
 
Reported: 2015-03-02 23:14 UTC by Carlos Munoz
Modified: 2015-04-20 00:29 UTC (History)
4 users (show)

Fixed In Version: 3.7.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3056)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-20 00:29:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1120034 None None None Never
Red Hat Bugzilla 1201718 None None None Never

Description Carlos Munoz 2015-03-02 23:14:37 UTC
Description of problem:
We are seeing some inconsistent times when pushing large translated document files. Specifically when pushing the libvirt project at: 
https://fedora.zanata.org/project/view/libvirt

This is a ~16000 text flow document.

Version-Release number of selected component (if applicable):
3.5


How reproducible:
As more translated documents are pushed in succession, the upload times increase. These times also seem to decrease sharply at points.

Steps to Reproduce:
1. Simply try to push multiple translated documents from this project.

Actual results:


Expected results:


Additional info:

Comment 1 Carlos Munoz 2015-03-02 23:17:10 UTC
Correction: document size is ~8000

Comment 2 Daniel Berrange 2015-03-03 09:11:48 UTC
FYI for testing you can get the po files easily from here:

  http://libvirt.org/git/?p=libvirt.git;a=tree;f=po;hb=HEAD

If you create a new project in zanata and then try to push the .pot & .po files here, I'd expect you to see the same behaviour that I experiance.

It isn't just a matter of inconsistent push times - it'll often to get to a point where the server simply causes the client to get a fatal error aborting the process.

Comment 3 Patrick Huang 2015-03-17 04:53:16 UTC
On my local machine before the change it looks something like this:
[INFO] Pushing target doc [name=libvirt size=6960 client-locale=de] to server [locale=de]
Done in 9 mins:49 secs
[INFO] Pushing target doc [name=libvirt size=7130 client-locale=ja] to server [locale=ja]
Done in 15 mins:12 secs
[INFO] Pushing target doc [name=libvirt size=3907 client-locale=pl] to server [locale=pl]
Done in 5 mins:45 secs
[INFO] Pushing target doc [name=libvirt size=6873 client-locale=zh-CN] to server [locale=zh-CN]
Done in 20 mins:35 secs
[INFO] Pushing target doc [name=libvirt size=2115 client-locale=it] to server [locale=it]
Done in 2 mins:56 secs
[INFO] Pushing target doc [name=libvirt size=6878 client-locale=es] to server [locale=es]
Done in 26 mins:48 secs
[INFO] Pushing target doc [name=libvirt size=8260 client-locale=uk] to server [locale=uk]
Done in 39 mins:38 secs
[INFO] Pushing target doc [name=libvirt size=2000 client-locale=fr] to server [locale=fr]
Done in 2 mins:59 secs
[INFO] Pushing target doc [name=libvirt size=939 client-locale=sq] to server [locale=sq]
Done in 46 secs


After the change it looks like this:
[INFO] Pushing target doc [name=libvirt size=6960 client-locale=de] to server [locale=de]
Done in 58 secs
[INFO] Pushing target doc [name=libvirt size=7130 client-locale=ja] to server [locale=ja]
Done in 54 secs
[INFO] Pushing target doc [name=libvirt size=3907 client-locale=pl] to server [locale=pl]
Done in 30 secs
[INFO] Pushing target doc [name=libvirt size=6873 client-locale=zh-CN] to server [locale=zh-CN]
Done in 1 mins:4 secs
[INFO] Pushing target doc [name=libvirt size=2115 client-locale=it] to server [locale=it]
Done in 19 secs
[INFO] Pushing target doc [name=libvirt size=6878 client-locale=es] to server [locale=es]
Done in 58 secs
[INFO] Pushing target doc [name=libvirt size=8260 client-locale=uk] to server [locale=uk]
Done in 1 mins:14 secs
[INFO] Pushing target doc [name=libvirt size=2000 client-locale=fr] to server [locale=fr]
Done in 18 secs
[INFO] Pushing target doc [name=libvirt size=939 client-locale=sq] to server [locale=sq]
Done in 10 secs
[INFO] Pushing target doc [name=libvirt size=8141 client-locale=mr] to server [locale=mr]
Done in 1 mins:25 secs
[INFO] Pushing target doc [name=libvirt size=7544 client-locale=ta] to server [locale=ta]
Done in 1 mins:22 secs
[INFO] Pushing target doc [name=libvirt size=6996 client-locale=pt-BR] to server [locale=pt-BR]
Done in 1 mins:16 secs

Comment 4 Patrick Huang 2015-03-17 04:53:50 UTC
https://github.com/zanata/zanata-server/pull/733

Comment 5 Carlos Munoz 2015-03-17 04:58:24 UTC
This should be targeted for a maintenance fix on the 3.6 branch.

Comment 6 Damian Jansen 2015-03-23 06:38:16 UTC
Verified (master) at 0206a8b242d6bfc3a5f63ffae1530930804328c8
Verified (release) at e553261205e458509d3268aa4acb7f2504667777


Note You need to log in before you can comment on or make changes to this bug.