Bug 1197910 - rhn-migrate-classic-to-rhsm: RHN deregister succeeds, subscription register fails, system DoSed
Summary: rhn-migrate-classic-to-rhsm: RHN deregister succeeds, subscription register f...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 00:10 UTC by Graham Leggett
Modified: 2015-04-07 18:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-07 18:52:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Graham Leggett 2015-03-03 00:10:32 UTC
When running the rhn-migrate-classic-to-rhsm command, the expectation was that the system would be deregistered from RHN classic and reregistered with subscription.

This doesn't happen.

Instead, the subscription registration fails, and the machine ends up unentitled and DoSed.

No explanation of any kind is generated during this process to explain why this script doesn't work. The admin is left clicking about the Redhat website in the dark.

[root@system images]# rhn-migrate-classic-to-rhsm
Red Hat username: username
Red Hat password: 

Retrieving existing RHN Classic subscription information...

+-----------------------------------------------------+
System is currently subscribed to these RHN Classic Channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
rhel-x86_64-server-optional-6-debuginfo
rhel-x86_64-server-6-debuginfo

+-----------------------------------------------------+
Installing product certificates for these RHN Classic channels:
+-----------------------------------------------------+
rhel-x86_64-server-6
rhel-x86_64-server-optional-6-debuginfo
rhel-x86_64-server-6-debuginfo

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic...
System successfully unregistered from RHN Classic.

Attempting to register system to Red Hat Subscription Management...
The system has been registered with ID: [uuid] 
System '[host]' successfully registered to Red Hat Subscription Management.

Attempting to auto-attach to appropriate subscriptions...
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Unable to find available subscriptions for all your installed products.

Unable to auto-attach.  Do your existing subscriptions match the products installed on this system?

Please visit https://access.redhat.com/management/consumers/[uuid] to view the details, and to make changes if necessary.

Comment 2 John Sefler 2015-03-03 16:58:09 UTC
This is not a problem with the rhn-migrate-classic-to-rhsm tool.  It is working correctly.  In fact, the tool left you registered using RHSM.

The problem is that your RHSM organization does not appear to have a RHEL subscription available for you to consume.  Maybe they have been exhausted by other consumers.  Log into the customer portal and review what subscriptions are available to your organization.

Or open subscription-manager-gui and review what is on the "All Available" tab.

Or on the command like run "subscription-manager list --all --available"

Comment 3 Graham Leggett 2015-03-03 17:57:22 UTC
It should not be possible for a system that was just unregistered from RHN to suddenly not have enough licenses on subscription-manager - unless subscription-manager is detecting the wrong number of sockets and therefore is applying the wrong number of licenses.

The detect-wrong-sockets bug is raised here: https://bugzilla.redhat.com/show_bug.cgi?id=1198283

Comment 4 John Sefler 2015-03-03 23:06:05 UTC
RHN and RHSM do not share the same entitlement engines.  These are two different technologies.  Relinquishing an entitlement from RHN does not imply that an equivalent entitlement becomes available in RHSM.

Comment 5 Graham Leggett 2015-03-03 23:37:57 UTC
Are you saying that in order to migrate from RHN to RHSM that you need to buy the entitlements again?

What happens to the entitlements in HRN that are released by the rhn-migrate-classic-to-rhsm tool?

Comment 6 Devan Goodwin 2015-04-07 18:52:09 UTC
We do not believe there is a bug here, but you may need to work with your sales rep or global support services to understand why you have no subscriptions available in the RHSM entitlement model.

Comment 7 Graham Leggett 2015-04-07 18:56:13 UTC
Yep, there was a bug here, and was described in https://bugzilla.redhat.com/show_bug.cgi?id=1198283 - it had nothing to do with the sales rep.

In case other people encounter this problem, the Linux kernel misidentifies some boards as having the wrong number of sockets, and this causes the re-registration to fail.

At the advice of the Redhat partner, we have been advised to avoid migrating from classic to rhsm as there are still too many bugs that need working out.


Note You need to log in before you can comment on or make changes to this bug.