Bug 119797 - Update pcitable, Cards, and pciids.sf.net for cyrix and nsc drivers
Summary: Update pcitable, Cards, and pciids.sf.net for cyrix and nsc drivers
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hwdata   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 119788 FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-04-02 07:12 UTC by Mike A. Harris
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 15:13:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2004-04-02 07:12:31 UTC
Update the pcitable, Cards, and pciids.sf.net to match what is
supported by the current "cyrix" and "nsc" drivers in Xorg X11.

Comment 1 Mike A. Harris 2005-02-01 09:45:21 UTC
This one is tricky, because the cyrix and nsc drivers share the
same PCI IDs with a bit of overlap.  As such, there is no way
to uniquely determine which driver should be used.  We should
just ensure the PCI IDs all exist in pcitable and map to some
driver.  The problem of which driver to use is deeper and should
be dealt with upstream in X.Org instead.

Comment 2 Mike A. Harris 2005-03-15 15:13:39 UTC
Rawhide hwdata is up to date with 6.8.2 for this driver.

The cyrix/nsc PCI ID confusion is a problem that needs to be resolved
upstream in the respective drivers.  I've filed an upstream bug report
for that problem.

https://bugs.freedesktop.org/show_bug.cgi?id=2737


Note You need to log in before you can comment on or make changes to this bug.