Bug 1197973 - help text for token_duration confusing
Summary: help text for token_duration confusing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact:
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 05:51 UTC by Fred van Zwieten
Modified: 2019-09-26 18:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:49:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 10194 None None None 2016-04-22 15:43:18 UTC
Red Hat Bugzilla 1656029 None None None Never
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Internal Links: 1656029

Description Fred van Zwieten 2015-03-03 05:51:17 UTC
Description of problem:
The help text provided for token_duration in the administer -> settings -> provisioning -> token_duration is confusing. It suggests that specifying a value of zero disabled the time-out (meaning the token will never time-out), while it actually means that no token will be generated at all, which will make unattended provisioning across subnets impossible.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
"Time in minutes installation tokens should be valid for, 0 to disable"

Expected results:
"Time in minutes installation tokens should be valid for, 0 to disable token-generation"

Additional info:
Suggestion to remove the possibility to disable token generation. This means check that the value will always be > 0. Then change the help text to "Time in minutes installation tokens should be valid for"

Comment 1 RHEL Program Management 2015-03-03 20:19:23 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-04-17 20:12:42 UTC
Created redmine issue http://projects.theforeman.org/issues/10194 from this bug

Comment 4 Bryan Kearney 2015-05-01 16:05:24 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10194 has been closed
-------------
Ondrej Prazak
Applied in changeset commit:615728bea09913031537d9b5841284228c983257.

Comment 5 Lukas Zapletal 2015-08-27 14:22:33 UTC
I see this was shipped in 6.1 GA :-)

Comment 8 errata-xmlrpc 2016-07-27 08:49:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.