Bug 1197993 - migration fail as qemu-kvm: load of migration failed: Invalid argument
Summary: migration fail as qemu-kvm: load of migration failed: Invalid argument
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: All
high
high
Target Milestone: rc
: ---
Assignee: Juan Quintela
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 07:03 UTC by Xiaoqing Wei
Modified: 2016-07-29 21:58 UTC (History)
16 users (show)

Fixed In Version: qemu 2.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:30:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Xiaoqing Wei 2015-03-03 07:03:00 UTC
Description of problem:

migration fail as qemu-kvm: load of migration failed: Invalid argument

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.2.0-5.el7.x86_64

How reproducible:
12/12

Steps to Reproduce:
1. start two vm, one as src, one as dst

/bin/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc  \
    -nodefaults  \
    -vga std  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20150303-142810-5RfgljJU,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20150303-142810-5RfgljJU,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20150303-142810-5RfgljJU,path=/tmp/seabios-20150303-142810-5RfgljJU,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20150303-142810-5RfgljJU,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2008-r2-64-virtio.qcow2 \
    -device ide-hd,id=image1,drive=drive_image1,bus=ide.0,unit=0 \
    -device virtio-net-pci,mac=9a:31:32:33:34:35,id=ideDYGXY,vectors=4,netdev=idzKFzlB,bus=pci.0,addr=04  \
    -netdev tap,id=idzKFzlB,vhost=on,vhostfd=36,fd=35  \
    -m 4096  \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2  \
    -cpu 'Opteron_G5',hv_relaxed,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=05 \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/ISO/Win2008R2/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso \
    -device scsi-cd,id=cd1,drive=drive_cd1 \
    -drive id=drive_winutils,if=none,snapshot=off,aio=native,media=cdrom,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device scsi-cd,id=winutils,drive=drive_winutils \
    -drive id=drive_virtio,if=none,snapshot=off,aio=native,media=cdrom,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/virtio-win.iso.el7 \
    -device scsi-cd,id=virtio,drive=drive_virtio \
    -drive id=drive_fl,if=none,cache=none,snapshot=off,readonly=off,aio=native,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2008-r2-64/answer.vfd \
    -global isa-fdc.driveA=drive_fl \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :1  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off,strict=off \
    -enable-kvm \
    -incoming tcp:0:5200


2. migrate starts
3.

Actual results:
Unknown savevm section type 5
qemu-kvm: load of migration failed: Invalid argument

Expected results:
migration finished success

Additional info:
same env & cli works on qemu-kvm-rhev-2.1.2-23.el7_1.1.x86_64

Comment 2 Dr. David Alan Gilbert 2015-03-03 15:52:42 UTC
This is probably the stuff Paolo fixed after 2.2.0 - it's known to fix Windows 2003 migration, so I'd expect it to be the same stuff.
It's fixed in head, and in what should be 2.2.1 as well.

Comment 3 saayeesundarraj.ganesan 2015-05-22 05:06:20 UTC
Hi David,

Please let me know in which link we can download this "qemu-kvm-rhev" latest RPMs, as the link "http://people.redhat.com/gcase/.a76c469f03d87b/ " is not working.

Thanks,
Saayee Sundar Raj

Comment 8 juzhang 2015-09-07 02:50:05 UTC
Hi mrezanin,

Could you please add this bz to qemu-kvm-rhev erratum?

Best Regards,
Junyi

Comment 9 juzhang 2015-09-07 02:50:42 UTC
According to comment6, set this issue as verified.

Comment 10 Miroslav Rezanina 2015-09-07 04:56:14 UTC
Hi Junyi,
yes, it has to get proper flags to be able to add to erratum. I'll negotiate the flags.

Mirek

Comment 12 errata-xmlrpc 2015-12-04 16:30:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html

Comment 13 Marina Kalinin 2016-05-24 20:22:04 UTC
Hi Juan,

I have a case where I get a similar error in qemu log:

2016-05-24T12:38:40.223467Z qemu-kvm: Unknown combination of migration flags: 0
2016-05-24T12:38:40.224147Z qemu-kvm: error while loading state section id 2(ram)
2016-05-24T12:38:40.224499Z qemu-kvm: load of migration failed: Invalid argument

Once I get libvirt logs, I will open a new bug for this, unless it looks same to you.

dest host:
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64

source host:
qemu-kvm-rhev-2.3.0 - 31.el7_2.13.x86_64

Comment 14 Dr. David Alan Gilbert 2016-05-31 12:04:23 UTC
Marina: Please open that as a new bz and state the number; it's not the same as this one (different state section and you've got the unknown combination of flags).
I'd bet in your case it's the source dieing first.


Note You need to log in before you can comment on or make changes to this bug.