Bug 1198016 - qemu will hang when specify "-realtime mlock=on" and "-sandbox on" at the same time
Summary: qemu will hang when specify "-realtime mlock=on" and "-sandbox on" at the sam...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: All
high
high
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 08:45 UTC by jinliu
Modified: 2015-12-04 16:31 UTC (History)
7 users (show)

Fixed In Version: qemu-2.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:31:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description jinliu 2015-03-03 08:45:10 UTC
Description of problem:
when using "-realtime mlock=on" and "-sandbox on" at the same time, qemu-kvm will hang.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.2.0-5.el7.x86_64
host kernel:
3.10.0-230.el7.x86_64
Guest kernel:
3.10.0-230.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot guest with "-realtime mlock=on" and "-sandbox on". cli as followings:
# /usr/libexec/qemu-kvm -realtime mlock=on -sandbox on -monitor stdio
2.
3.

Actual results:
After step 1, qemu-kvm will hang.

Expected results:
After step 1, qemu-kvm works well.

Additional info:

Comment 2 jinliu 2015-03-03 09:22:42 UTC
I also test with qemu-kvm-rhev-2.1.2-23.el7.x86_64, don't hit this issue. So QE add "Regression" keyword. 

Any mistake, free to correct me. Thx.

Comment 6 mazhang 2015-06-11 03:15:01 UTC
Reproduce this bug on qemu-kvm-rhev-2.2.0-9.el7.x86_64.

Host:
qemu-kvm-rhev-2.2.0-9.el7.x86_64
3.10.0-262.el7.x86_64

Steps:
Start qemu-kvm with:
/usr/libexec/qemu-kvm -realtime mlock=on -sandbox on -monitor stdio

Result:
qemu-kvm hang.

# ps ax |grep qemu
19960 pts/0    Zl+    0:00 [qemu-kvm] <defunct>


Verify this bug on qemu-kvm-rhev-2.3.0-2.el7.

Result:
qemu-kvm works well.
#  /usr/libexec/qemu-kvm -realtime mlock=on -sandbox on -monitor stdio
QEMU 2.3.0 monitor - type 'help' for more information
(qemu) VNC server running on `::1:5900'

(qemu) 
(qemu) info status
VM status: running

So this bug has been fixed.

Comment 10 errata-xmlrpc 2015-12-04 16:31:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.