Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1198023 - cairo_t/surface leak on gaussian filters
Summary: cairo_t/surface leak on gaussian filters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: librsvg2
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 09:15 UTC by plioski
Modified: 2015-10-19 12:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-19 12:18:14 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of memory usage (113.69 KB, image/png)
2015-08-01 12:11 UTC, Stefan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 748608 0 None None None Never

Description plioski 2015-03-03 09:15:32 UTC
Since last update (mid January), tracker can't correctly complete file indexing.
If I follow tracker-extract progress I can see that it reaches about 30%, then it occupies all available memory (swap and RAM), slowing down all computer activiries, and then it stops.
I tried several times to reset tracker database and restart indexing, but it fails everytime, also after removing lots of file from my home directory.

Comment 1 Stefan 2015-08-01 12:11:49 UTC
Created attachment 1058282 [details]
Screenshot of memory usage

Comment 2 Stefan 2015-08-01 12:12:34 UTC
I am having the same issue on Fedora 22 with tracker 1.4.0.

After a reset of the tracker database, tracker is unable to finish indexing because all my memory are consumed.

After 17 minutes of uptime - the computer is unusable.

Comment 3 Stefan 2015-08-01 17:43:52 UTC
Upstream bug report: https://bugzilla.gnome.org/show_bug.cgi?id=748608

Comment 4 Stefan 2015-08-04 11:46:33 UTC
In my case, librsvg is the root cause for the memory leak. For me, adding *.svg to the global ignore list for tracker is a valid workaround 

The upstream bugreport had identified a memory leak in librsvg.


Note You need to log in before you can comment on or make changes to this bug.