Bug 119803 - usermount doesn't ask for root password.
Summary: usermount doesn't ask for root password.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks: 122683
TreeView+ depends on / blocked
 
Reported: 2004-04-02 07:15 UTC by Brian "netdragon" Bober
Modified: 2013-07-02 22:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 12:27:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian "netdragon" Bober 2004-04-02 07:15:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When you go to the Gnome Panel > System Tools > Disk Management, you
get error: "There are no filesystems which you are allowed to mount or
unmount. Contact the Administrator."

I assume this is due to SELinux. Shouldn't it give you a chance to use
it as root, or explain how to change this?

Btw, how DO you change this? I do know a workaround is to login as
root in the terminal and type: "usermount"

Version-Release number of selected component (if applicable):
usermode-gtk-1.69-5

How reproducible:
Always

Steps to Reproduce:

    

Additional info:

Comment 1 Colin Charles 2004-05-06 06:35:49 UTC
This seems to be fixed with the latest rawhide tree, which go with
versions:

usermode-1.70-2
usermode-gtk-1.70-2

A regular test3 install with all the default SELinux options.

Comment 2 Brian "netdragon" Bober 2004-05-07 00:06:57 UTC
That's because SELnux is disabled in test3

Comment 3 Jindrich Novy 2004-12-17 12:27:39 UTC
This is not the case any more, the SELinux stuff is now fixed in
usermode. However we had to face a similar problem recently. The
problem was the error message:

"There are no filesystems which you are allowed to mount or
unmount. Contact the Administrator."

was displayed when you tried to use usermount as non-root and was
caused by HAL, that replaces "user" in /etc/fstab with "pamconsole"
for security reasons.

This is fixed now in rawhide.


Note You need to log in before you can comment on or make changes to this bug.