Bug 1198112 - [RFE] Support GSS Proxy installation and configuration in the installer
Summary: [RFE] Support GSS Proxy installation and configuration in the installer
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 12:19 UTC by Jan Pazdziora
Modified: 2019-10-10 09:39 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:11:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Pazdziora 2015-03-03 12:19:48 UTC
Description of problem:

When direct AD integration of the Satellite machine is used, the key for the HTTP/ service is the same as the host/ key. Or indeed, the same /etc/krb5.keytab can be used for HTTP/ as well if KrbServiceName Any is used. That means attack against the Apache service will be able to impersonate the whole host.

It is essential for this setup to separate access to the keytab. The GSS-Proxy project (available in RHEL 7.0) can achieve this -- the Apache HTTP server does not need to have access to the keytab at all. Even for non-AD scenarios, shielding the daemon from the key material has benefits. For generic Apache description, see https://fedorahosted.org/gss-proxy/wiki/Apache.

Satellite 6 installer should take advantage of this possibility and configure GSS-Proxy, either based on some explicit option, and for some scenarios like direct AD integration, by default.

Version-Release number of selected component (if applicable):

Satellite 6.0.x.

How reproducible:

Deterministic.

Steps to Reproduce:
1. Configure Satellite 6 with external authentication against IPA using --foreman-ipa-authentication=true, or when the RFE in bug 1198103 is addressed to make it easily possible to configure directly against AD, setup that.
2. Check the setup.

Actual results:

The file /etc/httpd/conf/http.keytab is readable by apache user.

Expected results:

The file /etc/httpd/conf/http.keytab is not readable by apache user, it probably does not exist at all, and Kerberos SSO still works.

Additional info:

Comment 1 Jan Pazdziora 2015-03-03 12:20:17 UTC
This should likely go hand in hand with move to mod_auth_gssapi, see bug 1198106.

Comment 2 RHEL Program Management 2015-03-03 20:19:14 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 16 Bryan Kearney 2018-09-04 18:59:22 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 17 Bryan Kearney 2018-09-04 19:11:14 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.