Bug 119822 - Cannot add/remove packages due to python errors and undefined symbols in rpm lib
Cannot add/remove packages due to python errors and undefined symbols in rpm lib
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-02 09:00 EST by Prentis Brooks
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 17:48:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prentis Brooks 2004-04-02 09:00:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Execution of system-config-packages fails due to an undefined symbol.
 This is a clean install of core2 test2:


[root@magetower prentis]# system-config-packages
Traceback (most recent call last):
  File "/usr/share/system-config-packages/MainWindow.py", line 16, in ?
    import method
  File "/usr/share/system-config-packages/method.py", line 15, in ?
    import GroupSet
  File "/usr/share/system-config-packages/GroupSet.py", line 20, in ?
    import rpm
ImportError: /usr/lib/python2.3/site-packages/rpmmodule.so: undefined
symbol: rpmdsBT
[root@magetower prentis]# rpm -q system-config-packages
system-config-packages-1.2.10-1


Version-Release number of selected component (if applicable):
system-config-packages-1.2.10-1

How reproducible:
Always

Steps to Reproduce:
1. execute system-config-packages as root
2.
3.
    

Actual Results:  Error reported and application exited

Expected Results:  GUI should have appeared to allow me to modify
installed applications.

Additional info:
Comment 1 Jeremy Katz 2004-05-06 17:48:46 EDT
You didn't have a match version of rpm and rpm-python.

Note You need to log in before you can comment on or make changes to this bug.