Bug 1198442 - dnf-plugins-core package does not work with dnf package in rawhide
dnf-plugins-core package does not work with dnf package in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-04 02:18 EST by Jens Petersen
Modified: 2015-11-06 14:35 EST (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.6-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-21 15:26:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec fix (1.63 KB, patch)
2015-03-04 03:13 EST, Marcin Juszkiewicz
no flags Details | Diff

  None (edit)
Description Jens Petersen 2015-03-04 02:18:32 EST
Description of problem:
Not sure what is causing this - it works fine for me in F22.

Version-Release number of selected component (if applicable):
dnf-0.6.4-2.fc23
dnf-plugins-core-0.1.5-1.fc22

Steps to Reproduce:
1. Install F23 rawhide (minimal+base install)
2. try to run "dnf repoquery"

Actual results:
"No such command: repoquery. Please use dnf --help"

Expected results:
repoquery to work

Additional info:
(I noticed that the build dnf-plugins-core-0.1.5-2.fc23 failed.)
Comment 1 Jens Petersen 2015-03-04 02:51:11 EST
hrw informed me on #fedora-devel that this might be know and due
to f23 dnf having moved to python3 but not plugins-core yet.
Comment 2 Marcin Juszkiewicz 2015-03-04 02:57:11 EST
To be more precise:

dnf/f23 is using python3 now by default.
dnf-plugins-core/f23 fails to build due to lack of python3 version of python-kickstart:

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.plbYnV
+ umask 022
+ cd /builddir/build/BUILD
+ cd dnf-plugins-core
+ PYTHONPATH=./plugins
+ /usr/bin/nosetests-2.7 -s tests/
............E.............
======================================================================
ERROR: Failure: ImportError (No module named pykickstart.parser)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/loader.py", line 414, in loadTestsFromName
    addr.filename, addr.module)
  File "/usr/lib/python2.7/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib/python2.7/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/builddir/build/BUILD/dnf-plugins-core/tests/test_kickstart.py", line 29, in <module>
    import kickstart
  File "/builddir/build/BUILD/dnf-plugins-core/plugins/kickstart.py", line 25, in <module>
    import pykickstart.parser
ImportError: No module named pykickstart.parser
----------------------------------------------------------------------
Ran 26 tests in 0.020s
FAILED (errors=1)
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.plbYnV (%check)
    Bad exit status from /var/tmp/rpm-tmp.plbYnV (%check)
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
 # bash --login -c /usr/bin/rpmbuild -bb --target noarch --nodeps  /builddir/build/SPECS/dnf-plugins-core.spec 

http://koji.fedoraproject.org/koji/taskinfo?taskID=9135435 is scratch build.
Comment 3 Marcin Juszkiewicz 2015-03-04 03:13:44 EST
Created attachment 997764 [details]
spec fix

To be exact the issue is lack of Python2 kickstart. Attached spec change adds missing build dependency.
Comment 4 Marcin Juszkiewicz 2015-03-04 03:16:00 EST
https://hrw.fedorapeople.org/dnf-plugins-core-0.1.5-2.fc23.hrw1.src.rpm/ contains packages and logs from build.
Comment 5 Parag Nemade 2015-03-04 03:28:55 EST
Note, the discussion to fix F23 spec is still going on in upstream https://github.com/rpm-software-management/dnf-plugins-core/pull/66
Comment 6 Marcin Juszkiewicz 2015-03-04 03:33:45 EST
Parag: thanks, added comment there
Comment 7 Radek Holy 2015-03-04 05:07:18 EST
This is an unfortunate situation. As a workaround, please install python3-dnf-plugins-core. We are working on the fix.
Comment 8 Honza Silhan 2015-03-06 06:53:06 EST
fixed in the upstream.
Comment 9 Fedora Update System 2015-04-09 10:41:03 EDT
dnf-plugins-core-0.1.6-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.6-3.fc22
Comment 10 Fedora Update System 2015-04-10 14:21:31 EDT
Package dnf-plugins-core-0.1.6-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.6-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5951/dnf-plugins-core-0.1.6-3.fc22
then log in and leave karma (feedback).
Comment 11 Matt Mullins 2015-04-17 19:17:11 EDT
I'm still seeing a failure to install any of the previously-mentioned packages:

[mmullins@rawhide ~]$ sudo dnf install dnf-plugins-core
Fedora 22 - x86_64 - Test Updates   28 MB/s |  13 MB     00:00    
Fedora 22 - x86_64 - Updates       4.4 kB/s | 335  B     00:00    
Using metadata from Fri Apr 17 16:15:51 2015 (0:00:06 hours old)
Error: nothing provides pykickstart needed by python-dnf-plugins-core-0.1.6-3.fc22.noarch
[mmullins@rawhide ~]$ sudo dnf install python3-dnf-plugins-core
Using metadata from Fri Apr 17 16:15:51 2015 (0:00:24 hours old)
Error: nothing provides python3-chardet needed by python3-requests-2.5.3-2.fc22.noarch
Comment 12 Matt Mullins 2015-04-17 20:20:21 EDT
Please disregard my previous comment.  That particular machine seems to have had an inconsistent set of repositories configured; a clean F22 install can dependency-solve for dnf-plugins-core just fine.
Comment 13 Fedora Update System 2015-04-21 15:26:07 EDT
dnf-plugins-core-0.1.6-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Nestor Waldyd 2015-11-06 14:33:36 EST
Hello,

I am having a problem upgrading from F21 using 'dnf system-upgrade':


[waldyd@localhost-live ~]$ sudo dnf system-upgrade download --releasever 22
Using metadata from Thu Nov  5 11:13:34 2015 (1 day, 3:11:07 hours old)
Error: nothing provides kernel-uname-r = 4.2.3-200.fc22.i686+PAE needed by kmod-VirtualBox-4.2.3-200.fc22.i686+PAE-4.3.32-1.fc22.i686.
nothing provides kernel-uname-r = 4.2.3-200.fc22.i686 needed by kmod-VirtualBox-4.2.3-200.fc22.i686-4.3.32-1.fc22.i686


Any ideas about how to resolve this?
Comment 15 Nestor Waldyd 2015-11-06 14:35:44 EST
[waldyd@localhost-live ~]$ dnf --version
0.6.4
  Installed: dnf-0:0.6.4-7.fc21.noarch at 2015-10-20 21:51
  Built    : Fedora Project at 2015-09-23 14:30

  Installed: rpm-0:4.12.0.1-7.fc21.i686 at 2015-07-29 21:16
  Built    : Fedora Project at 2015-06-15 07:11

Note You need to log in before you can comment on or make changes to this bug.