Bug 1198454 - Cannot add label to an existing node via openshift cli
Summary: Cannot add label to an existing node via openshift cli
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ravi Sankar
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-04 08:07 UTC by Meng Bo
Modified: 2015-05-15 03:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 18:00:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Meng Bo 2015-03-04 08:07:36 UTC
Description of problem:
Setup openshift-v3 env with master and nodes, try to add label to the existing minions, will fail with traceback.

Version-Release number of selected component (if applicable):
openshift v0.3.4-8-gb175b35
kubernetes v0.10.0-503-gc977a45

How reproducible:
always

Steps to Reproduce:
1. Setup openshift-v3 env via vagrant
2. Get the Ready node 
3. Add label to the node above

Actual results:
Will fail with traceback.
Detail please refer to: http://fpaste.org/192630/

Expected results:
Should be able to add label to node like other resources.

Additional info:
It is able to add label to other resources like pod:
[vagrant@openshiftdev ~]$ openshift kube label pods hello-openshift k=v
POD                 IP                  CONTAINER(S)        IMAGE(S)                    HOST                           LABELS                     STATUS
hello-openshift     172.17.0.7          hello-openshift     openshift/hello-openshift   openshiftdev.local/127.0.0.1   k=v,name=hello-openshift   Running

Comment 1 Meng Bo 2015-03-25 02:53:08 UTC
Seems the issue has been fixed with the latest code,

[vagrant@openshift-master ~]$ openshift kube label node openshift-minion-1 key=val
NAME                 LABELS              STATUS
openshift-minion-1   key=val             Schedulable,Ready

Comment 2 Ravi Sankar 2015-03-31 00:44:43 UTC
Yes, No longer reproducible on the latest code. Looks like this is fixed in the k8s upstream.


Note You need to log in before you can comment on or make changes to this bug.