Bug 119847 - builtin wireless does not honor ONBOOT=no
Summary: builtin wireless does not honor ONBOOT=no
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-02 16:40 UTC by Bill Rankin
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 17:28:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Rankin 2004-04-02 16:40:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.12

Description of problem:
The machine is a Dell C400 laptop with builtin PCMCIA wireless. 

The network was configured through system-config-network to never
bring up any of the network connections during boot (since the laptop
moves between several network environments).  However on boot, this
setting seems to be ignored by the PCMCIA startup scripts and the
wireless interface is initialized and made active.

There is a bit of code in /etc/pcmcis/network.opt which seems suspect:

if [ -z "$IPADDR" -a -f /etc/sysconfig/network-scripts/ifcfg-$2 ] ; then
    INFO="Red Hat netconf setup"
    start_fn () {
        . /etc/sysconfig/network-scripts/ifcfg-$1
        if [ "$ONBOOT" = "yes" ] ; then log /sbin/ifup $1 ; fi
    }
    stop_fn () {
        log /sbin/ifdown $1
    }
fi

but my bash scripting is not up to par, so this could be okay.  I was
just wondering about the switching between $1 and $2.


Version-Release number of selected component (if applicable):
initscripts-7.48-1

How reproducible:
Always

Steps to Reproduce:
1. boot system
2. ifconfig
3.
    

Actual Results:  /dev/eth2 (wireless card) is active.

Expected Results:  no external interfaces should be active

Additional info:

Comment 1 Bill Nottingham 2004-04-02 17:28:56 UTC
You can add 'ONHOTPLUG=no' to the config file; that should solve this.

Comment 2 Bill Rankin 2004-04-02 19:00:55 UTC
It's actually 'HOTPLUG=no'.

'ONBOOT=NO' also works.

But since these config files will be overwritten by the system-config
tools, and HOTPLUG=no is not an option in the config files, is this
not still a bug in the network configuration tools?

Comment 3 Bill Nottingham 2004-04-02 19:52:04 UTC
Well, *ideally* this will all get replaced by 'onlink=<yes|no>', and
that will apply to boot, hotplug, or whatever. Or something similar.

But that's not been coded up yet.


Note You need to log in before you can comment on or make changes to this bug.