Bug 1198631 - [RHEVM 3.5] upgrade script should check for which version is installing.
Summary: [RHEVM 3.5] upgrade script should check for which version is installing.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-04 14:42 UTC by Ulhas Surse
Modified: 2019-04-28 09:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-09 09:06:54 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Ulhas Surse 2015-03-04 14:42:56 UTC
Description of problem:
While upgrading from any RHEVM version, for example 3.2 to 3.3/ 3.3 to 3.4/ 3.4 to 3.5, the script should check and display which is current installed version and what next version should be installed. 

Say if installed version is 3.3 and I subscribed to 3.5 channels, it should stop the upgrade process saying that "Your current installation is 3.3 and you must upgrade to 3.4 first and then to 3.5" something like that.

Version-Release number of selected component (if applicable):
RHEVM any version 

How reproducible:
Always 

Steps to Reproduce:
1. Install rhevm 3.3/ 3.4 
2. Upgrade to 3.5 
3. The setup/ upgrade should check and display message which next version should be installed. 

Actual results:
Upgrade continues even if the version is latest.

Expected results:
Upgrade should stop if version sequence is not followed.

Additional info:

Comment 2 Sandro Bonazzola 2015-03-09 09:06:54 UTC
Hi,
In rhev 3.5 the rhevm-setup 3.5 package as a conflict with rhevm < 3.4.0 so it's not possible to upgrade directly from 3.3 to 3.5.

At the same way, rhevm-setup 3.4 has a conflict with rhevm < 3.3.1 so it's not possible to upgrade directly from 3.2 to 3.4.

According to expected result in original comment I'm closing this as not a bug since the issue has been already addressed.
Please reopen if you find that described behaviour is not followed.


Note You need to log in before you can comment on or make changes to this bug.