Bug 1198671 - zsh hangs in rt_sig state in getoutput()
Summary: zsh hangs in rt_sig state in getoutput()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: zsh
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: beta
: 7.3
Assignee: Kamil Dudka
QA Contact: Jan Kepler
URL:
Whiteboard:
: 1311172 (view as bug list)
Depends On:
Blocks: 1311166 1338663 1622892
TreeView+ depends on / blocked
 
Reported: 2015-03-04 15:32 UTC by Filip Krska
Modified: 2018-08-28 08:50 UTC (History)
5 users (show)

Fixed In Version: zsh-5.0.2-19.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1338663 (view as bug list)
Environment:
Last Closed: 2016-11-03 23:01:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2152 normal SHIPPED_LIVE zsh bug fix update 2016-11-03 13:13:01 UTC

Comment 5 Kamil Dudka 2015-08-10 10:58:08 UTC
A similar issues is now discussed in the following thread on upstream ML:

http://www.zsh.org/mla/workers/2015/msg01897.html

Two patches were applied to address it recently:

http://sourceforge.net/p/zsh/code/ci/99586845
http://sourceforge.net/p/zsh/code/ci/df5f8255

The solution does not seem to be ready for RHEL yet.  One of the patches currently breaks the upstream test-suite on Intel x86_64:

http://www.zsh.org/mla/workers/2015/msg01961.html

Comment 6 Kamil Dudka 2015-08-10 16:15:54 UTC
The following upstream commit makes the test-suite work again:

http://sourceforge.net/p/zsh/code/ci/a07f74fa

Comment 7 Kamil Dudka 2015-08-11 14:55:36 UTC
Yet another follow-up commit upstream:

http://sourceforge.net/p/zsh/code/ci/93ca77f8

Comment 8 Kamil Dudka 2015-08-11 17:24:42 UTC
Two more upstream commits on this topic:

http://sourceforge.net/p/zsh/code/ci/1af2e6e0
http://sourceforge.net/p/zsh/code/ci/128bf385

Comment 9 Kamil Dudka 2015-08-17 08:26:04 UTC
One more commit upstream:

http://sourceforge.net/p/zsh/code/ci/5d019f42

Comment 10 Kamil Dudka 2015-09-10 14:38:11 UTC
One more commit upstream:

http://sourceforge.net/p/zsh/code/ci/9f5dffa1

Comment 11 Kamil Dudka 2016-03-01 12:31:04 UTC
The above patches may change the order of execution under some circumstances, which can be observed as a change in behavior inappropriate for RHEL-6 in its current phase of life.

I am moving this bug to RHEL-7 but for RHEL-6 I will pick the fixes that look safe enough to be applied on RHEL-6 (the signal queuing guards around code using heap memory allocation).  I will use bug #1311166 for the RHEL-6 fixes.

Comment 12 Kamil Dudka 2016-03-01 12:40:07 UTC
*** Bug 1311172 has been marked as a duplicate of this bug. ***

Comment 14 Kamil Dudka 2016-03-01 15:31:26 UTC
I have picked one more upstream commit to make sure that pattern matching will not become less interruptible because of the other upstream patches that were backported:

http://sourceforge.net/p/zsh/code/ci/8672d19f

Comment 19 Kamil Dudka 2016-03-09 16:08:42 UTC
This seems to be also related (although more about interactive use of zsh):

https://sourceforge.net/p/zsh/code/ci/f4dfca49

Comment 29 errata-xmlrpc 2016-11-03 23:01:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2152.html


Note You need to log in before you can comment on or make changes to this bug.