Bug 1198711 - libunwind package needs source update for ppc64le
Summary: libunwind package needs source update for ppc64le
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: libunwind
Version: epel7
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Martuccelli
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7ppc64le
TreeView+ depends on / blocked
 
Reported: 2015-03-04 16:54 UTC by Éric Fintzel
Modified: 2015-12-07 01:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 01:33:15 UTC


Attachments (Terms of Use)
libunwind-fix-ppc64_test_altivec.patch (404 bytes, patch)
2015-05-21 13:55 UTC, Menanteau Guy
no flags Details | Diff

Description Éric Fintzel 2015-03-04 16:54:52 UTC
Description of problem:

Source package libunwind-1.1-3 used by EPEL7 does not support ppc64le.
A newer version supporting this architecture should be used instead.

Comment 1 Tom "spot" Callaway 2015-03-30 19:55:30 UTC
There is no stable release of libunwind that supports ppc64le. It looks like there is some code in git to add support, but I'm not comfortable cherry picking code from git here. I think your best bet is to open an issue with the libunwind upstream asking for a stable release based on the git code:

http://www.nongnu.org/libunwind/

Comment 2 Menanteau Guy 2015-05-21 13:55:09 UTC
Created attachment 1028197 [details]
libunwind-fix-ppc64_test_altivec.patch

Comment 3 Menanteau Guy 2015-05-21 13:56:16 UTC
What do you mean by "no stable release of libunwind that supports ppc64le" ?
At least for build, a libunwind ppc64le seems exist.

I see in http://ppc.koji.fedoraproject.org/koji/packageinfo?packageID=3743
a libunwind-1.1-5 built for ppc64le no so far from the libunwind-1.1-3 currently used in epel7.
Only differences are:  
- Replacing ppc64 with the power64 macro (#1051641) 
- Link test_ppc64_altivec against libunwind in tests/Makefile.am to fix build on ppc64.

First corresponding to a change in the spec
- ExclusiveArch: %{arm} aarch64 hppa ia64 mips ppc ppc64 %{ix86} x86_64
+ ExclusiveArch: %{arm} aarch64 hppa ia64 mips ppc %{power64} %{ix86} x86_64

And second is the add of libunwind-fix-ppc64_test_altivec.patch

Comment 4 Tom "spot" Callaway 2015-05-21 14:13:14 UTC
Are you sure it actually works though? If you've tested that libunwind code on ppc64le and confirmed proper functionality, I'll fix the spec to enable it as a target.

Comment 5 Menanteau Guy 2015-05-21 14:52:22 UTC
Didn't test it, this is why I asked you what did you mean by "support".
My comment was only relative to build.
I will try to test it when I get some time.

Comment 7 Peter Robinson 2015-12-07 01:33:15 UTC
Now shipped in RHEL 7 but only for x86_64


Note You need to log in before you can comment on or make changes to this bug.