Bug 119874 - No bootloader found 2.6.4-1.303.i686 rpm install
No bootloader found 2.6.4-1.303.i686 rpm install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 13:27 EST by Tom Mitchell
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 06:16:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Mitchell 2004-04-02 13:27:59 EST
Description of problem:
Installing 2.6.4-1.303 does not seem to get the boot loader correct.
 (yum update of kernel 2.6.4-1.303.i686)

Version-Release number of selected component (if applicable):
   kernel 2.6.4-1.303.i686
   kernel-source 2.6.4-1.303.i386  ,-- not realy involved..


How reproducible:
 Yes, rpm -e and tried again same trouble.
 verified by one other

Steps to Reproduce:
1.yum update kernel kernel-source 
 
2.answer yes to kernel 2.6.4-1.303.i686, kernel-source 2.6.4-1.303.i386

3.Is this ok [y/N]: y
  
Actual results:
# yum update
Gathering header information file(s) from server(s)
Server: Fedora Core 1.91 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
[install: kernel 2.6.4-1.303.i686]
[install: kernel-source 2.6.4-1.303.i386]
Is this ok [y/N]: y
Downloading Packages
Running test transaction:
Test transaction complete, Success!
kernel-source 100 % done 1/2
kernel 100 % done 2/2
/bin/bash: /root/.bashrc: Permission denied
Kernel Updated/Installed, checking for bootloader
No bootloader found, Cannot configure kernel, continuing.
Installed:  kernel 2.6.4-1.303.i686 kernel-source 2.6.4-1.303.i386
Transaction(s) Complete
# id
uid=0(root) gid=0(root)
+groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel)
+context=root:sysadm_r:sysadm_t

On reboot the root FS  is not found
and the kernel panics

Expected results:
 expected the boot proces to be ok.


Additional info:

Selecting a previous kernel works so the
bulk of the boot process is ok.

Same problem enforcing=[0|1]
Comment 1 Darin May 2004-04-02 14:12:50 EST
When installing the 303 rpm or during a kernel compile I get:

sh /usr/src/linux-2.6.4-1.303/arch/i386/boot/install.sh
2.6.4-1.303custom arch/i386/boot/bzImage System.map ""
No module ieee1394 found for kernel 2.6.4-1.303custom, aborting.
mkinitrd failed
Comment 2 Dave Jones 2004-04-02 14:44:30 EST
the vfs problem:- boot with the option vdso=0 and it should work again

ieee1394 - this is still broken, so is still disabled.
Comment 3 Tom Mitchell 2004-04-02 18:03:28 EST
 Thanks.
Booted with vdso=0 and the kernel  2.6.4-1.303
is up and running.
Comment 4 Brian "netdragon" Bober 2004-04-02 20:28:14 EST
I kept trying to install kernel 2.6.4-1.303 with up2date, and it 
either froze, or didn't appear in rpm -qa (though kernel-source did). 
I finally got it installed with yum, but it didn't appear on the boot 
list when I rebooted. 

So I tried booting into 2.6.3-2.1.253.2.1 again and got this output:

root(hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.3-2.1.253.2.1 ro root=LABEL=/ rhgb quiet
   [Linux-bzImage, setup=0x1400, size=0x127a72]
initrd /initrd-2.6.3-2.1.253.2.1.img
   [Linux-initrd @ 0x37fad000, 0x4296a bytes]
default=0

Error 27: Unrecognized command

Press any key to continue...

(Back to boot screen)


So I booted into the CD and did linux rescue, mounted the root 
partition, and then the /boot partition and went into grub/menu.lst 
and added the stuff for the 2.4 kernel and set it as default. 
Unfortunately, there was no initrd file for 2.4 so I set it to the 
initrd for 2.6.3 thinking I was screwed anyway...

Booted into 2.4, got a kernel panic... No init found, not surprised..
.

vdso=0 does nothing, as its like the missing initrd... Yet, I have no 
idea why I can't boot from the 2.6.3 kernel anymore... 2.6.4 kernel 
rpm must have messed something up. 

I've heard there are problems with the 2.6 kernel and redhat, and I 
don't know if this is related. It seemed to stem from issues with 
up2date or rpm because that's where they started.

I'm going to reinstall everything fresh, reformatting the disk, etc..
. then see if this can be reproduced.
Comment 5 Marshall Boykin 2004-04-02 23:20:29 EST
I got the same type of error, but I was using up2date to update ONLY 
the kernel and source. I thought it might have been from the SeLinux, 
so I re-installed using the C2T1 disk1, then switched to C2T2 disk1, 
install went fine. During this install I disabled SeLinux from the 
firewall screen, instead of setting it to permissive. Went back to 
up2date and downloaded only the kernel and source (both times it was 
kernel-2.6.4-1.303.i386.rpm, kernel-2.6.4-1.303.i686.rpm, and kernel-
source-2.6.4-1.303.rpm)and both times I got this error: 
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
Unable to handle kernel paging request at virtual address fffef020
  printing eip:
ffff3102
*pde = 00002067
Oops: 0000 [#1]
CPU:	0
EIP:	0060:[<ffff3102>] Not tainted
EFLAGS:	00010283	(2.6.4-1.303)
EIP is at )xffff3102
eax: 00000040	ebx: 00000000	ecx: 00000000	edx: 00000000
esi: 00000000	edi: 00000000	ebp: feeb4b40	esp: 21cb5ff0
ds: 007b	es: 007b	ss: 0068
Process linuxrc (pid: 11, threadinfo=21cb5000 task=21633980)
Stack: 00000073 00000283 feeb4b40 0000007b
Call Trace:

Code: ff b4 24 30 e0 ff ff 50 fc 06 1e 50 55 57 56 52 51 53 ba 7b
 VFS: Cannot open root device "LABEL=/" or unknown-block(0,0)
 Please append a correct "root=" boot option
 Kernel panic: VFS: Unable to mount fs on unknown-block(0,0)  
I am able to boot with the 2.6.4-1.289 kernel fine.
Comment 6 Arjan van de Ven 2004-04-06 06:16:13 EDT
305 ought to be ok again...

Note You need to log in before you can comment on or make changes to this bug.