Bug 119877 - Rename file to .something doesn't rename the file and the file is lost
Rename file to .something doesn't rename the file and the file is lost
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 13:42 EST by Santiago Erquicia
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 09:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Santiago Erquicia 2004-04-02 13:42:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
When you rename a file to one that starts with a dot, it doesn't
update the view and it actually doesn't renames the file.

The icon it's shown as "filename", if you click over it, it says in
the status bar ".filename".  If you reload the folder, you no longer
have the file (changing preferences to see hidden files)

Version-Release number of selected component (if applicable):
nautilus-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1.create a text file in a folder
2.name it "test"
3.rename it as ".test"
    

Actual Results:  The file is lost and the view is not updated

Expected Results:  rename the file while showing it until you refresh
the view

Additional info:

I tried with the browser view of nautilus and it works.  It seems that
the problem is only with the spatial view
Comment 1 Santiago Erquicia 2004-05-07 17:04:46 EDT
I tried again with FC2 test 2 updated up today and it doesn't happen.
 I don't know if it is something about fam or not (just a guess, I
heard that fam is enabled now)
Comment 2 Alexander Larsson 2004-09-06 09:04:57 EDT
Seems to work for me too in rawhide.

Note You need to log in before you can comment on or make changes to this bug.