Bug 119882 - iptables 1.2.8-12 save/restore broken
Summary: iptables 1.2.8-12 save/restore broken
Status: CLOSED DUPLICATE of bug 111999
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iptables (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-02 19:29 UTC by John Berninger
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Berninger 2004-04-02 19:29:22 UTC
Description of problem:
service iptables save with icmp protocol matching broken

Version-Release number of selected component (if applicable):
iptables-1.2.8-12

How reproducible:
always

Steps to Reproduce:
1. service iptables stop
2. iptables -A INPUT -p icmp -m icmp -j ACCEPT
3. service iptables save
4. service iptables stop
5. service iptables start
  
Actual results:
Applying iptables firewall rules: Bad argument 'any'
Error occurred at line: 6
Try `iptables-restore -h' or `iptables-restore --help' for more
information
                     [ FAILED ]

[root@ul init.d]# cat /etc/sysconfig/iptables
# Generated by iptables-save v1.2.8 on Fri Apr  2 14:16:19 2004
*filter
:INPUT ACCEPT [686:56746]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [677:49614]
-A INPUT -p icmp -m icmp any -j ACCEPT
COMMIT
# Completed on Fri Apr  2 14:16:19 2004
                                                                     
          

Expected results:
Success.
[root@ul init.d]# cat /etc/sysconfig/iptables
# Generated by iptables-save v1.2.8 on Fri Apr  2 14:16:19 2004
*filter
:INPUT ACCEPT [686:56746]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [677:49614]
-A INPUT -p icmp -m icmp --icmp-type any -j ACCEPT
COMMIT
# Completed on Fri Apr  2 14:16:19 2004
                                                                     
          


Additional info:

Comment 1 Thomas Woerner 2004-04-06 08:24:27 UTC

*** This bug has been marked as a duplicate of 111999 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:02:21 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.