Bug 1198821 - instack-undercloud: "Polling discoverd for discovery results" stage gets stuck.
Summary: instack-undercloud: "Polling discoverd for discovery results" stage gets stuck.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Alexander Chuzhoy
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-04 21:30 UTC by Alexander Chuzhoy
Modified: 2015-08-05 13:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Alexander Chuzhoy 2015-03-04 21:30:38 UTC
instack-undercloud: "Polling discoverd for discovery results" stage gets stuck.

Environment:
instack-0.0.6.4-g57c723a.el7.centos.noarch
instack-undercloud-2.0.0-dev1399.g710b7c1.el7.centos.noarch


Steps to reproduce:
1. instack-ironic-deployment --nodes-json instackenv.json --register-nodes 
2. instack-ironic-deployment --discover-nodes


Result:
The discovery gets stuck:

   Polling discoverd for discovery results ...                                               
       Result for node 04b84cc6-6778-4ac5-9378-9244c9e87d09 is ... DISCOVERED.               
       Result for node 3e0bfaff-c7aa-4323-a1f2-274791c0480d is ... DISCOVERED.               
       Result for node 9fb5794c-f23e-4860-8f80-fd0f1b085c1a is ...  


Expected result:
All the nodes should be discovered without getting stuck.


The W/A is to login to the hypervisor and to turn off the baremetal_X instance that's running.

Comment 4 Alexander Chuzhoy 2015-06-01 20:59:00 UTC
Verified:
instack-0.0.6-5.el7ost.noarch
instack-undercloud-2.1.0-3.el7ost.noarch

The reported issue doesn't reproduce.

Comment 8 errata-xmlrpc 2015-08-05 13:50:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.