Bug 1198833 - hammer: content-view version list failed
Summary: hammer: content-view version list failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1221126 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-04 22:19 UTC by sthirugn@redhat.com
Modified: 2017-02-23 20:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 13:56:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman production.log (40.98 KB, text/plain)
2015-03-04 22:19 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 9741 0 None None None 2016-04-22 16:48:23 UTC

Description sthirugn@redhat.com 2015-03-04 22:19:42 UTC
Created attachment 998079 [details]
foreman production.log

Description of problem:
content-view version list failed

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150303.0

How reproducible:
Always

Steps to Reproduce:
hammer> content-view version list --help
Usage:
     content-view version list [OPTIONS]

Options:
 --composite-version-id COMPOSITE_VERSION_ID Filter versions that are components in the specified composite version
 --content-view CONTENT_VIEW_NAME            Content view name
 --content-view-id CONTENT_VIEW_ID           content view numeric identifier
 --environment ENVIRONMENT_NAME              Name to search by
 --environment-id ENVIRONMENT_ID              
 --version VERSION                           Filter versions by version number
 -h, --help                                  print help


hammer> content-view version list --content-view=cv1
undefined method `pulp_id' for nil:NilClass


Actual results:
Error as shown above (foreman production.log attached)

Expected results:
content view versions listed

Additional info:

Comment 2 Partha Aji 2015-03-12 22:05:48 UTC
Created redmine issue http://projects.theforeman.org/issues/9741 from this bug

Comment 3 Partha Aji 2015-03-12 22:14:38 UTC
should be fixed when https://github.com/Katello/katello/pull/5107 gets merged to master.

Comment 4 Bryan Kearney 2015-03-18 20:05:17 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9741 has been closed
-------------
Partha Aji
Applied in changeset commit:katello|a7a6192f7318c5083801ef4efe51061e8c31749f.

Comment 6 sthirugn@redhat.com 2015-04-27 16:43:56 UTC
Verified.

Version Tested: Satellite-6.1.0-RHEL-6-20150424.0

# hammer -u admin -p changeme content-view version list --content-view=rhel6cv
---|-------------------------------|---------|-----------------------
ID | NAME                          | VERSION | LIFECYCLE ENVIRONMENTS
---|-------------------------------|---------|-----------------------
1  | Default Organization View 1.0 | 1.0     | Library               
2  | Default Organization View 1.0 | 1.0     | Library               
3  | rhel6cv 1.0                   | 1.0     | Library, QE           
4  | bulkrhel6cv 1.0               | 1.0     | Library, QE           
---|-------------------------------|---------|-----------------------

Comment 7 Brad Buckingham 2015-05-15 15:56:45 UTC
*** Bug 1221126 has been marked as a duplicate of this bug. ***

Comment 8 Bryan Kearney 2015-08-11 13:30:09 UTC
This bug is slated to be released with Satellite 6.1.

Comment 9 Bryan Kearney 2015-08-12 13:56:15 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.