Bug 1198905 - [RFE][ironic]: API Microversions
Summary: [RFE][ironic]: API Microversions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: Upstream M3
: 7.0 (Kilo)
Assignee: RHOS Maint
QA Contact: Raviv Bar-Tal
URL: https://blueprints.launchpad.net/iron...
Whiteboard: upstream_milestone_kilo-3 upstream_de...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-05 05:02 UTC by RHOS Integration
Modified: 2016-11-25 13:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-25 13:40:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description RHOS Integration 2015-03-05 05:02:56 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/ironic/+spec/api-microversions.

Description:

Add documentation about how Ironic and clients should interact negotiating which version of the REST API to use.

Specification URL (additional information):

http://git.openstack.org/cgit/openstack/ironic-specs/plain/specs/kilo/api-microversions.rst


Note You need to log in before you can comment on or make changes to this bug.