Bug 1198922 - Evolution constantly requests for authentication (caldav google 2factor auth)
Summary: Evolution constantly requests for authentication (caldav google 2factor auth)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-05 06:24 UTC by Chester Moy
Modified: 2015-03-24 14:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 10:20:13 UTC
Type: Bug


Attachments (Terms of Use)
wrong username (22.46 KB, image/png)
2015-03-05 06:24 UTC, Chester Moy
no flags Details

Description Chester Moy 2015-03-05 06:24:08 UTC
Created attachment 998165 [details]
wrong username

Description of problem:

Sync google calendars to evolution using CalDav because of 2factor not working well with libgdata ()

The calendar is correctly set up, because the events are viewable in evolution. However, every so often, I am prompted for authentication. Furthermore, it uses the wrong username for authentication.

Let's say that my gmail is HDresden and my linux username is moymoy.
Evolution will periodically prompt me for authentication to log moymoy into google servers.

Version-Release number of selected component (if applicable):
Evolution: 3.11
Gnome: 3.14.2

How reproducible:
always

Steps to Reproduce:
1. Add new Calendar
2. Select CalDav
3. Enter gmail username and email
4. Click Choose calendar from list
6. Enter App specific password
7. Select calendar
8. Add calendar

9. Wait

Actual results:
Calendars will sync correctly, but evolution will periodically ask for authentication. It will wrongly try to authenticate the unix username to the caldav host.

Expected results:
Calendar syncs correctly, and that's the end of it.


Additional info:

Comment 1 Milan Crha 2015-03-05 10:20:13 UTC
Thanks for a bug report. Evolution doesn't get the user name out of nowhere, it is set in the Calendar Properties, field "User", just above Find Calendars button. You should correct it to the right one. It is prefilled as a local account login when entering a new Calendar, but that doesn't mean it should be used, as you see.

Comment 2 Chester Moy 2015-03-05 22:28:20 UTC
(In reply to Milan Crha from comment #1)
> Thanks for a bug report. Evolution doesn't get the user name out of nowhere,
> it is set in the Calendar Properties, field "User", just above Find
> Calendars button. You should correct it to the right one. It is prefilled as
> a local account login when entering a new Calendar, but that doesn't mean it
> should be used, as you see.

I saw that it was prefilled with my linux username right away. I corrected it to my google account.

My point is that I filled it with the correct username. I correctly authenticate to Google, and the calendar is sync'd up to Evolution through calDav. All my events are now visible through Evolution. And changes made through Evolution are reflected on the web.

But every now and then, I get prompted again for authentication, but it's with the wrong username. I just click cancel over and over until it stops bothering me.

Comment 3 Chester Moy 2015-03-06 02:43:17 UTC
So I set the calendar up again after a few restarts and there doesn't seem to be a problem anymore.

It's strange because it was so reproducible before. Not to mention everything was syncing just fine even when I was experiencing the problem.

I'll just chalk it up to overall glitchiness since the reason I had to restart a couple of times was because a few of my keyboard shortcuts stopped working (configured through settings -> keyboard -> shortcuts).

Comment 4 Milan Crha 2015-03-06 05:24:13 UTC
(In reply to somethingsome2000+redhat from comment #2)
> My point is that I filled it with the correct username. I correctly
> authenticate to Google, and the calendar is sync'd up to Evolution through
> calDav. All my events are now visible through Evolution. And changes made
> through Evolution are reflected on the web.

Hmm, that's really odd. I do not think I saw anything like that before. Did you create a Google account in GNOME Online Accounts too, or everything was done directly in Evolution?

Comment 5 Chester Moy 2015-03-24 08:52:57 UTC
Both. I first set up my Google account through GNOME. I then found out that Evolution was only syncing one of my calendars, so I tried adding the rest. That's when it happened.

Comment 6 Milan Crha 2015-03-24 14:28:38 UTC
It can be that you face [1]. I wasn't able to reproduce it myself.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=734694


Note You need to log in before you can comment on or make changes to this bug.